Partha's Rawtherapee Build gtk-3 Crashing - opening .jpg [Resolved]


(Morgan Hardwood) #21

We will need a stack backtrace from you @Andrew_Clarke or from someone who can reproduce.


(Andrew Clarke) #22

I have no experience with C++ and no experience at compiling an C++ .app, my mac is setup for Python development, how could i give you a stack backtrace in a simple way, other than installing GDB, even if it would in Patha’s version.


(Andrew Clarke) #23

Ok I have installed GDB and it appears that it is running but I am getting no executable file ? Any pointers ?

Andrews-MBP:/ andrewclarke$ gdb -ex=r /Applications/RawTherapee-gtk3.app/Contents/MacOS/rawtherapee
GNU gdb (GDB) 7.12.1
Copyright © 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying"
and “show warranty” for details.
This GDB was configured as “x86_64-apple-darwin16.3.0”.
Type “show configuration” for configuration details.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/.
Find the GDB manual and other documentation resources online at:
http://www.gnu.org/software/gdb/documentation/.
For help, type “help”.
Type “apropos word” to search for commands related to “word”…
”/Applications/RawTherapee-gtk3.app/Contents/MacOS/rawtherapee": not in executable format: File format not recognized
Starting program:
No executable file specified.
Use the “file” or “exec-file” command.


(Morgan Hardwood) #24

@Andrew_Clarke
/Applications/RawTherapee-gtk3.app/Contents/MacOS/rawtherapee
is a script which, after doing some stuff, calls the real rawtherapee binary
/Applications/RawTherapee-gtk3.app/Contents/Resources/bin/rawtherapee

You have three options:

  1. First run RawTherapee, then attach GDB to the running program.
  • You need to know the process ID, to find it install pidof: brew install pidof
  • Run RawTherapee
  • In a terminal type pidof rawtherapee That will give you a number, e.g. 12345.
  • Then attach GDB to RT: gdb -p 12345
  • Now open that JPEG, and if RT crashes then alt+tab back to GDB and type bt full and all that other jazz as described in “how to write useful bug reports”.
  1. Or edit /Applications/RawTherapee-gtk3.app/Contents/MacOS/rawtherapee and edit the last line from
    exec "./rawtherapee" "$@"
    to
    exec gdb "./rawtherapee"
  • Save it, then when you run RT you will automatically run GDB. Type run to start the real RT, then trigger the crash, bt full, etc.
  1. Or try this (it might not work at all, but if it does its probably the simplest way):
    gdb --args bash /Applications/RawTherapee-gtk3.app/Contents/MacOS/rawtherapee

#25

@Andrew_Clarke, Could you please download the latest and tell us if it is still crashing?

@Morgan_Hardwood, I’ve put in some fixes that I have tested that seems to fix the crash with exif data.


(Andrew Clarke) #26

Thanks Morgan, I have tried the above, I can only get gdb to work by using sudo, when this does it seems to lock the program up, and the timing wheel appears when i click on the program window.

Attaching to process 6758
[New Thread 0x1803 of process 6758]
[New Thread 0x1903 of process 6758]
[New Thread 0x1a03 of process 6758]
[New Thread 0x1b03 of process 6758]
[New Thread 0x1c03 of process 6758]
[New Thread 0x1d03 of process 6758]
[New Thread 0x1e03 of process 6758]
Reading symbols from /Applications/RawTherapee-gtk3.app/Contents/Resources/bin/rawtherapee…(no debugging symbols found)…done.

warning: unhandled dyld version (15)
0x00007fffc297838a in ?? ()


(Andrew Clarke) #27

@partha - downloaded the latest and this seems to of fixed the crashing.
Thanks


#28

@Andrew_Clarke, Thanks for testing.


#29

I think that we haven’t seen a mac 5.0r1 debug build yet, so i dont see how gdb would be able to make sense of the process without using a debug build. Correct me if im mistaken.


(Morgan Hardwood) #30

@HIRAM debug builds give more info, but you don’t always need it to find the problem. In the absence of a debug build, a stack backtrace from a release build is better than nothing.


(Morgan Hardwood) #31

Great that you found and fixed the problem. Was this a packaging issue or a C++ one? If C++, please supply a patch on GitHub.


#32

@Morgan_Hardwood, No, not an issue with RT but with cairo/libexif combination.

But it could be an RT issue. I have not completely investigated that yet. Note that McGimp does not crash on the jpegs that RT crashes on, on the Mac.


(Andrew Clarke) #33

@partha -

Note that McGimp does not crash on the jpegs that RT crashes on, on the Mac .

I can confirm no crash on jpg’s on McGimp 2.8.14 64-bit or your other versions that RT crashes on.

(I do have an issue with printing on McGimp 2.8.14 64-bit - where is the best place to post that issue.)


#34

@Andrew_Clarke, Please contact me at my email address to discuss McGimp. Thanks!


(Andrew Clarke) #35

Thanks I have sent you an email.


#36

@partha, I just tried out your latest gtk3 app, seems to open the troublesome jpg generated by google earth I was having problems with before without any problem. Do get the crash when trying to change the batch processor save location. Scrollbars work nice. Very fine work!

Version: 5.0-r1-gtk3
Branch: releases
Commit: 50114c1a
Commit date: 2017-02-01
Compiler: cc 8.0.0.8000042
Processor: generic x86
System: Apple
Bit depth: 64 bits
Gtkmm: V3.22.0
Build type: Release
Build flags: -stdlib=libc++ -std=c++14 -O3 -mmacosx-version-min=10.9 -std=gnu++11 -mtune=generic -Werror=unused-label -O3 -DNDEBUG
Link flags: -headerpad_max_install_names -mtune=generic
OpenMP support: ON
MMAP support: ON

& For @toowaboo A Screen Shot
Theme=TooWaBlue-Dark
Font=Noto Sans 12 pt


Excellent theme work!


#37

Thanks for the feedback :blush:


#38

@partha @ion12 See my post in a new thread here: A weird crash in Partha's build, can't reproduce in ion12's build


(Ingo Weyrich) #39

That’s great. We are also trying to solve some old clang related restrictions. That would speedup denoise for rt clang builds!


A weird crash in Partha's build, can't reproduce in ion12's build