PhotoFlow News and Updates

photoflow
news

(Shreedhar Inamdar) #289

I confirm @afre’s report. I downloaded photoflow-w64-20180721_1120-git-stable in the zip format, unzipped and tried opening the coffee-drops raw file and it crashed. I also have photoflow-w64-gtk3-20180612_1657-git-stable and the same file opened all right with it.


(Carmelo Dr Raw) #290

@afre @shreedhar I could reproduce the issue on my Win10 tablet, and I am investigating. In fact, in my case I am not able to open any image, RAW or Jpeg…


#291

Only tried a raw file when I reported the problem. Just tried opening a JPG and can confirm. Hope you can get to the bottom of this shortly. Otherwise, I won’t be able to try your latest commit. :sob:


(Carmelo Dr Raw) #292

@afre @shreedhar I have prepared a new Win64 package that should solve the recent issues (it worked fine on my Win10 tablet). Could you please check if you can now open files correctly?

The new package comes with an improved crop tool, that should be more intuitive to use. The work is not yet finished, but I hope I am going in the good direction…


#293

Thanks. I opened a raw; no crash.

Feedback on crop tool.
– Good: crop box doesn’t start a 0 anymore.
– Good: no longer able to move the boundaries outside of the image with the guides.
– Bad: still able to enter numerical values combinations that move the crop box outside.
– Should: the entire area of the corner boxes should control the diagonal resizing.
– Bad: when trying to resize vertically using the top rectangle, the mouse jumps to the NE corner.
– Should: the crop box shouldn’t shrink to 1 px widths and heights; GUI essentially disappears.
– Maybe: if the edge or corner moves past the 1 px mark, maybe invert the box; feels intuitive.
– Maybe: provide a more intuitive and / or conventional way to commit. :wink:


(Shreedhar Inamdar) #294

Yes @Carmelo_DrRaw, it works now. Also, I liked the improved crop tool. :+1:


(Carmelo Dr Raw) #295

I have done some changes in the way “interactive” tools (those which can be controlled/adjusted by using mouse gestures in the preview area, like the crop tool) behave, in particular how the interactive adjustments can be enabled/disabled. You can read more about that in this blog post.

Any feedback is very much appreciated!


(Shreedhar Inamdar) #296

testing with coffee mug PLAY RAW. Absolutely no issues so far and the turning on and off the editing mode works quite fast. Cheers :slightly_smiling_face:


(Carmelo Dr Raw) #297

Thanks for the feedback, and glad to hear that it works fine!


(Carmelo Dr Raw) #298

I have added a small but useful enhancement to the UI - a panel showing the EXIF data of the edited image:

More info in the blog: https://photoflowblog.blogspot.com/2018/10/photoflow-exif-data-info-panel.html


#299

I have two suggestions.

1. Make the mouse more visible. It nearly disappears against the grey in win10.

mouse

2. Include an indication if lens corrections are possible given the camera-lens combo.


FYI, there are still many situations where the camera-lens combos are detected but nothing really happens when the corrections are applied besides the shifting of the preview due to its redrawing.


(Carmelo Dr Raw) #300

Should be easy to do… I’ll look into that.

Could you provide me some sample RAW files that exhibit this problem?

Thanks!


(Elle Stone) #301

Building the PhotoFlow plugin for GIMP-2.99 fails with the message that the correct version of GIMP can’t be found:

-- Checking for module 'gimp-2.0>=2.9.0'
--   Requested 'gimp-2.0 >= 2.9.0' but version of GIMP is 2.8.22

I’m guessing somehow in CMakeLists.txt 2.99 isn’t detected as greater than 2.9.0 and also some of GIMP-2.99 files go in folders named “gimp-3.0” and some in folders named “2.99”.


(Carmelo Dr Raw) #302

@Elle
I suspect that the pkgconfig file is called gimp-3.0.pc in 2.99.
Could you check if you have such a file in your $prefix/lib/pkgconfig folder?

I will update the cmake configuration accordingly.

Thanks!


(Elle Stone) #303

Yes, there is this file. Here’s the contents:

prefix=/home/elle/code-install/gimp299/install
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include
datarootdir=${prefix}/share

gimpdatadir=${datarootdir}/gimp/2.99
gimplibdir=${exec_prefix}/lib/gimp/2.99
gimpsysconfdir=${prefix}/etc/gimp/2.99
gimplocaledir=${datarootdir}/locale

Name: GIMP
Description: GIMP Library
Version: 2.99.1
Requires: gdk-pixbuf-2.0 >= 2.30.8 cairo >= 1.14.0 gegl-0.4 >= 0.4.9
Libs: -L${libdir} -lgimp-3.0 -lgimpmath-3.0  -lgimpconfig-3.0 -lgimpcolor-3.0 -lgimpbase-3.0 
Cflags: -I${includedir}/gimp-3.0

Thanks!


(Carmelo Dr Raw) #304

I have introduced some small improvements in the soft-proofing code, particularly in the handling of black point compensation… now the “simulate black ink” option should always behave as expected.


#305

I am using photoflow-w64-20181010_1143 and cannot use WB Area; cannot draw a rectangle.


(Carmelo Dr Raw) #306

Hi @afre, sorry for the late answer… I think I know what’s wrong, will look into that as soon as I can.


#307

No problem. I am a very casual user. :smile:


(Carmelo Dr Raw) #308

:open_mouth::open_mouth::open_mouth::open_mouth::open_mouth: