PhotoFlow News and Updates

photoflow
news

#330

It is difficult to describe because the behaviour is inconsistent. If I turn on a sampler before I attempt Area WB, the Area rectangle control doesn’t appear. Except, now it does in the latest commit…

This last trial, the rectangle sometimes disappears and isn’t just invisible. I cannot access the rectangle or select the ROI for Area WB. Try doing the following:

1. Add another layer such as “tone mapping”.
2. Have the “raw developer” and “tone mapping” modules float.
3. Try different combinations of toggling the “tone mapping” layer, selecting either layer and toggling their respective edit pencils.

I know that there might be a state where the rectangle should be gone but right now the behaviour for #1-3 is unpredictable. Feels like the rectangle control randomly goes away and becomes inaccessible, leaving me scratching my head and giving up. Seems to me it is somehow getting better. At least, I was able to use Area WB for one of the recent PlayRaws.


(Elle Stone) #331

I tried to use the Area white balance today. I never did set any Sample Points. The Area rectangle just didn’t want to appear. So I gave up and closed PhotoFlow. I haven’t updated recently, if that matters.


#332

I often want to pixel peep more than 100%, something that I noticed that PF didn’t have right off the bat, but didn’t request it because it was a minor quibble. I don’t need interpolation, just bigger pixels. :slight_smile:

PS Zooming is particularly useful when I am using the defringe tool. I have trouble seeing and adjusting it without a huge zoom, often having to turn to RT (which is not a bad thing :stuck_out_tongue:) or exporting the image for examination in G’MIC.


PPS :thinking: Looks like something is wrong with the defringe tool. I exported 2 images, one without and the other with defringe. When I take the difference between the two, I get this. PFI: 20180603_140157.pfi (17.7 KB). Raw from [Play Raw] Peaceful mountain view.

PhotoFlow: left without defringe; right with it differenced and equalized (boosted).

pf_defringe

RawTherapee: left without defringe; right with it differenced and equalized (no boost).

rt_defringe

Looks like the defringing is only occurring in the brightest regions and not even the edges.

PhotoFlow: left without defringe; right with it differenced and equalized (boosted).


(Carmelo Dr Raw) #333

@afre @Elle I have just committed some improvements. Hopefully now the area WB will be more usable, as the rectangle with the target area should be visible whenever the RAW developer layer is selected.
I’d be very much interested to know if you find the new behaviour more intuitive than the previous…

I have also added the possibility to zoom in the image beyond 1:1, actually up to 800%. Pixel peepers will be happy!!!

I still need to look into the defringe tool problems, it’s the next item on the list.


#334

Area WB seems to work now.

The edit mode still needs some work. When I am using Area WB and try to toggle the edit pencil, it turns off briefly and then goes back on. The off and on makes PF go into processing twice, when nothing should be happening. The processing also happens when toggling the edit pencil in modules that don’t need the edit mode. (Ideally, the expected behaviour would be for the rectangle to be active only when the WB tab of the module is active.)

Lastly, it would be great to have a percent zoom status.


PS In the meantime, I have been using RT’s (dev) Raw > Chromatic Aberration and Detail > Defringe tools, which are both quite agreeable, if you wish to see what is going on there.


(Gustavo Adolfo) #335

Hi,
It’s been a while since I’ve used PF, so I’m probably not doing it right, but when I crop this image, it leaves a layer beneath the crop. Look at bottom and right sides.
What am I doing wrong?


IMG_4245.pfi (31.2 KB)
IMG_4245.DNG (17.8 MB)

Creative Commons License
These files are licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License .


#336

I made this observation a while ago. Basically, PF doesn’t have any conception of layer positioning. When you crop the upper layer, what happens is the dimensions shrink. The layer is drawn from the top-left, so it would start there and would essentially shift toward that point.

Now, if you move the crop outside and on top of the Group Layer, this crop should be affecting everything underneath and thus give you the desired effect.


(Gustavo Adolfo) #337

That’s it, thanks!


(Gustavo Adolfo) #338

Another thing that @afre may know about: the noise reduction layer has no effect, even when I drag the luma slider to 100.
I tried moving the NR layer outside the group, but nothing changes.


(Carmelo Dr Raw) #339

@afre was faster than me to reply… indeed, moving the crop layer outside of a group is the right solution. However, let me give you some background about what’s going on behind the curtain…

The crop tool is implemented in a way that completely disables the blending step. In other words, the crop output always replaces the contents of the underlying layers. Otherwise, the software would try to blend two images with a different size, with the result you have observed.

When the crop layer is inside a group, the blend mode of the group overrides the one of the crop layer, and performs a normal blend of two images with a different size…

If the crop layer in inside the group, and you set the group blend mode to “passthrough”, you should get the same result as if the crop layer was outside of the group.

That is not entirely true. The layers have an option to adjust their position relative to the input image. The translation is however not (yet) interactive, and must be set “by numbers” in two fields that can be accessed by expanding the “more” button below the opacity slider:
18

This is hidden by default to avoid filling the UI, as it is not used very frequently…


(Gustavo Adolfo) #340

Thanks for the explanation, it’s always good to have the big picture.

As for the lack of effect on noise reduction…


(Carmelo Dr Raw) #341

I will have a look at it as soon as possible. I must admit I am not using noise reduction very often…


#342

Oh, I didn’t notice that. A long while ago, I asked about this among other things and you didn’t answer on this particular item.


PS Last time I checked, there weren’t any releases for the OCIO branch. Was wondering when that would come. I would like to give it a try. Thanks.


I gave linear + log a brief go. Some things I noticed:
– When slope is high and linear range is low, there is a kink in the toe of the curve.
– When compression is low, the kink becomes crazier and not limited to the toe, or the curve bends backward.
– Overall, the default setting gives the best appearance out of all of the methods and their respective defaults.


(Gustavo Adolfo) #343

Hello!
Is it possible to manually select camera and lens in Raw Developer layer?
Clicking on Unknown Camera and Unknown Lens doesn’t open a dialog to pick a pair camera/lens like RT and DT.
Checking or unchecking the boxes below doesn’t help.
The thing is, even if my camera doesn’t show in the lensfun list, I usually get good results by choosing a similar model (in my case, Canon Powershot A640)
image


#344

If you have auto matching disabled, you should be able to click the Unknown camera or lens boxes to open a list.


(Carmelo Dr Raw) #345

Could you provide me a sample RAW file to test? I can then check if the manual camera/lens selection works or not…


#346

The artefact was due to a wrong handling of negative channel values, leading to NANs. This is fixed in the new packages from today (will be ready in a little while).

Having that sorted out is superb… I was trying to figure out what caused the artefacts and why if I exported say a scaled jpg it would have magically gone.

But latest releases introduced a really annoying behaviour: if I’m editing a stack and then photoflow hangs and I have to force quit it… when I try to reopen the pfi file, it inmediately crashes. I’ve tried to empty the cache folder, move the raw and pfi to another place without success. Basically I lost my edit :frowning_face: . This didn’t happen before. Is there anything I can I do to avoid this party of misery :ghost:?


#347

Don’t you have a time machine?

Maybe launch PF by console. That is what I do to log errors. Right now the output is good.


#348

That’s a good pro-active suggestion migo, thanks :blush:

Terminal output << trying to load pfi after force quit
PhF_crash_at_load_01.txt (112.3 KB)


#349

I mean do it every time you launch PF. That way when it crashes, you could copy the last part of the error output when you report the problem.