Photometric Color Calibration - Cannot download the online star catalog

Not sure wether I am the only one getting a error message when I try the Photometric Color Calibration.
It seems there is an issue when accessing the NOMAD star catalog…

Tonight servers are down I believe.

This is the error I’m getting when using PhCC:

Error loading url: http://cdsweb.u-strasbg.fr/cgi-bin/nph-sesame/-oI/A?M42: The specified location is not supported

The location itself exists.

The url is ok. Maybe the webservice was down when you tried it. It is possible.

It’s still happening.

Moreover, the error message in the console is instantaneous upon pressing ‘Find’. It’s not like it’s timing out as it’s happening too fast.

I should note that the url is http://cdsweb.u-strasbg.fr/cgi-bin/nph-sesame/-oI/A?M42 - the error message above effectively tacked a ‘:’ to the end of the url.

I get the same response with NGC and IC objects as well, so it’s not a Messier object issue.

It was working fine for me today.
I am using the latest version of Siril 0.99.6

For me it is working well too.

Capture d’écran du 2021-01-19 20-06-51

I’m using 0.99.7, both from the archive and compiled and getting it on both. I’m also getting it on two machines.

Screenshot_20210119_141437

Of note is another error message when Siril loaded:

Siril cannot access to https://gitlab.com/free-astro/siril/-/tags?sort=updated_desc

So you have a problem with your connection. Something is locking the connection to Siril. Your firewall? Something like that. I don’t know but fore sure this is on your side.

But that doesn’t make any sense… I can connect to those urls through a browser, so clearly the requests themselves are not being rejected by a firewall.

It’s also an instantaneous error. If it was a only a network connection issue it would take some time to time out.

It can’t just be on my end. There’s got to be a bit more to it than that.

Do you have glib-networking installed ?

I do.

I’ve now tested this using a wifi hotspot from my mobile phone, completely separate from my home network and ISP, with pretty much the same result.

What happens there is that I get a message of “Looking for updates…” below the command line on the Console tab when Siril starts up. That eventually fails with “Siril cannot access” error. The PhCC also fails, but fails instantly.

Using nethogs, I’m not even seeing an outbound request from Siril. By constrast, using KStars and telling it to download some orbital elements, I can see that it has made a request in nethogs.

Yes, for an unknown reason you cannot connect to the web with Siril.
On my Linux it is ok.

I don’t know. We use glib functions that generally work.

I just installed the older 0.99.6 .deb after removing the more recent 0.99.7 (siril and siril-common).

And that works. So it’s definitely not a connection problem at my end. It’s some sort of build problem.

Additionally, I can see the requests go out in nethogs from siril 0.99.6 at startup, as well as during PhCC object lookup and when actually running PhCC.

0.99.6 does not use same method to connect to the web. Now we use glib.

Fwiw, here’s what I’ve got installed on my system:

libglib2.0-dev-bin:
Installed: 2.66.1-2
Candidate: 2.66.1-2

libglib2.0-dev:
Installed: 2.66.1-2
Candidate: 2.66.1-2

glib-networking:
Installed: 2.66.0-2
Candidate: 2.66.0-2

Whether I use my own compiled 0.99.7 build or the slightly older 0.99.7 from the PPAs, the result is the same.

I’m stuck…
And with this appimage?

1 Like

Was this resolved? I’m having the same or a similar problem. This has been working beautifully for me. I love it. But recently, it doesn’t pick up the catalogues. And like @deyvidjeymz, it’s instantaneous. I uninstalled and reinstalled. No joy. Any suggestions? Kubuntu 20.04.

Update

15:04:55: Found 743 stars in image, channel #1 15:05:23: Error loading url: http://cdsweb.u-strasbg.fr/cgi-bin/nph-sesame/-oI/A?NGC281: The specified location is not supported

Tx.

Steve

DId you tried the appimage given just above?

1 Like