Photos in forum topics not being displayed - Ubuntu 18.04 LTS, Firefox 60.0.2 (64-bit)


(Gord) #1

I just did a clean install of Ubuntu 18.04 on my laptop, and when I view this forum on Firefox on this computer, images within the posts on this forum are not displayed. I didn’t have this problem with 16.04, nor with Manjaro, OpenSUSE or Windows. And on this computer, I don’t have this problem on another forum powered by Discourse (the Discourse demo forum), nor do I have problems viewing images on other web sites.

All this suggests that there is a setting in the forum that is causing my problem, but I can’t seem to find it. Any clues?


#2

I had a problem with embedded videos at one point. Turns out I had selected the strict block list setting in Firefox. However, I don’t think I had an image loading problem, save for the times when site maintenance is happening. Nothing that waiting a bit, flushing the cache and / or rebooting the machine won’t fix.


(Mica) #3

and clear those caches!


(Gord) #4

I already tried clearing the cache, rebooting, etc., and relaxed the privacy settings in Firefox. No difference. The problem is only occurring in discuss.pixls.us, not in other Discourse sites, and not on other web sites in general.

All I can think of is that it’s a third-party issue. The images are being served from
https://pixls-discuss.s3.amazonaws.com/
rather than from
https://discuss.pixls.us/

But I haven’t figured out the secret sauce to getting them to display yet.


(Mica) #5

Yes, discourse has the option to store images in an Amazon S3 bucket, which is way cheaper than paying via webhosting, so that is what we do :slight_smile:


(Gord) #6

That makes perfect sense.


#7

That is why I brought up the block list. I don’t know much about web development but have come across cross-domain / origin issues from time to time. If it isn’t the settings, do you have any privacy or data related apps, plugins or policies? Just brainstorming. :slight_smile:


(Martin Scharnke) #8

I’ve had this issue for a while - on first clicking into a discussion thread, no images.
But I found that if I then click on the title of the discussion above the first post, it refreshes and loads the images just fine.

I t may be peculiarities of particular browsers, rather than of OS. I’m using Falkon on Kubuntu 18.04


(Gord) #9

'fraid not. This is a fresh clean install. I have yet to add any of my usual add-ins to the browser yet, and have not blocked anything. I’ve even relaxed the browser settings from the defaults.


(Gord) #10

I have now also tried the same level of Firefox (60.0.2 64 bit) on openSUSE Leap 42.3 and Win 10 here, on different machines, with the same results. On the Windows box, I also got the same results with Chrome.

On a Windows machine I can remotely access, I can see the images in both Firefox and PaleMoon.


(Pat David) #11

I just tested on Ubuntu 18.04 with Firefox 60.0.2 and I can see images fine (browsing anonymously).
I also just tried logging in and it appears to work :confused: .

You can see what’s going on by opening the web console in Firefox, Ctrl-Shift-K:

Then navigate to a post that shows this problem. If there are any issues they should show up in the console (Cross-Origin policy problems, missing images, errors, etc…). We can get it fixed right up. :slight_smile:

I don’t think there’s a setting that would hide images for you, but I’ll try to take a look shortly and see what I can find (closing on a house this morning, so I may be afk - if so I’d defer to @paperdigits for now).


(Gord) #12

Good suggestion @patdavid! The console shows that the requests to
https://pixls-discuss.s3.amazonaws.com/
are not completing. Everything else finishes with the expected HTTP/2.0 200 OK.

I did a quick test with Firefox on my phone. I used this thread as a test case, since on the desktop I am not seeing the console image you included. With Wi-Fi enabled (meaning my request was going through my router/modem to my ISP), the image was not displayed. I turned off Wi-Fi, refreshed the page, and there was the image. So this may actually be a problem at my ISP!


#13

Which reminds me: I have encountered similar problems when using certain public or restaurant WIFIs. Could be the router(s), network and / or ISP.


(Gord) #14

I got surprisingly good support from my ISP (Bell Canada). They also could not reach https://pixls-discuss.s3.amazonaws.com/ from their systems. It looks like it’s a name server issue for them, and they have promised to rectify it and notify me within 24 hours.

Thanks to all here who provided help!


(Gord) #15

It appears to be fixed now. I can now see all images, including Pat’s fine one above!


(Pat David) #16

Wow. How do I get me some of that responsive Canadian internet?! :wink:

Comcast would have either told me hey can’t fix it, not their problem or charged me $100 to have a technician come check something on my end. :smiley:


#17

Rant :sweat:

The track record varies because everything is outsourced. There were 3 years many years ago, when Rogers had many problems with the service in my area. Internet, TV, phone, etc., were messed up. After 2 years, we tried to start a Bell service. Not only did we have poor and confusing customer service with but we paid 6 months for no service without a refund. We tried to escalate the issue on the phone and write letters but I kept on speaking to people in India, Texas and elsewhere, who had no clue which company we were with on file (because they were contractors to multiple companies from around the world).

These past 2 years, Bell upgraded its fibre lines city-wide, which is good. However, they dug up our lawns, roads and sidewalks randomly. Most of these holes and trenches weren’t used at all and took a year of waiting to be patch up. Very disruptive and costly. Now, there is a box on my yard, not the utility part. I hope the grass grows over it.


(Gord) #18

I was shocked (pleasantly) by the service. I was expecting rote answers that didn’t match my questions, which is what I have always received from Bell in the past.


(Gord) #20

This issue was reported for Firefox under Ubuntu 18.04, not Windows.

Your Firefox support link does not point to a Mozilla site.