Pix viewer from Linux Mint


(keith) #1

I thought this needed a thread of it’s own
Below is the post by Molke on Linux Lite, I thought it said it all :grinning:
****Pix
Pix is an advanced image viewer and browser from the X-apps family. It has many useful features, such as filesystem browsing, slide show, image catalogs, web album creation, camera import, image CD burning, batch file operations and quick image editing features like transformation and color manipulation. I tried this one in Linux Mint 17.3 “Rosa” and it’s been my image viewer of choice ever since. Pix isn’t officially supplied, you’ll need to add an unofficial repository, in the form of a new PPA. Enter these commands to your terminal to do so:

sudo add-apt-repository ppa:embrosyn/xapps
sudo apt-get update
sudo apt-get install pix

By the way, by adding this PPA to your system, you’ll be able to install any other X-app like Xreader, Xplayer, Xed and Xviewer.****


(Alberto) #2

Thanks for the link. I just tried it, but it doesn’t seem to be colour managed :frowning:


(Mica) #3

Isn’t it a fork of Eye of Mate/Eye of Gnome2?


#4

The readme mentions that it is “based on gThumb”.


#5

Pix is a part of an initiative by Linux Mint and Cinnamon devs called Xapps. https://github.com/linuxmint/xapps. Unsure how much of it is a yet-another but I am pretty sure that its goals are different from what is discussed in Would it makes sense to write a new image viewer from scratch?.


(Carmelo Dr Raw) #6

Probably you are right… I would say that the initial goals would be color accuracy, speed and input format support.


(Morgan Hardwood) #7

Its three features are fear, surprise, and ruthless efficiency… and an almost fanatical devotion to the Pope. Its four features are…


(Gord) #8

@Morgan_Hardwood Thanks, I needed that. I’d be in trouble if I wasn’t nailed to a perch right now.