PLEASE HELP: Darktable Tethering Issues with Canon

Hello there. I have searched everywhere online and not found a solution to this problem. I am not extremely technical but I can follow direction. It would be great if someone in this community could solve my problem.

Problem:
Image capture is not working with my Canon 70d connected to Darktable for tethering. When I am in tethering mode and take a picture it does not show up on the screen. It seems like the camera is transferring it to darktable (its not recording to the sd card) but nothing shows up and I have no record of the images anywhere…

What works:
The Camera consistently connects to Darktable and Darktable allows me to start a tethering session. I dont have any disconnection issues, the live view feature works in tethering and the camera controls works.

One weird thing:
The camera will only show up on DT when i plug it into (1) of my (2) USB 3.0 ports. If I plug into the other USB 3.0 port or the USB 2.0 port it does not show up on DT when I “scan for available devices”

Steps I have taken so far:
Latest firmware is on camera. sd card is empty, used Zadig (per DT website) to install WinUSB (v6.1.7600.16385) driver on camera so it will be recognized by DT. Dissabled all other programs that support the camera. Disabled Autoplay features for the camera, sd cards, etc in Windows. Tried multiple sequences of turning the camera on/off, program open/closed, uninstalling’reinstalling, etc, etc. Tried multiple different cable lengths (3’, 6’, 15’ doesnt make a difference). Tried multiple different lenses.

Info on my setup:
Lenovo y70, i7, 16gb ram, Nvidia Gforce 960gtx graphics card, Windows 10
Dartable version 2.6.2
Teather Tools 15’ Tethering cable USB 2.0
Canon 70D, Camera Firmware ver 1.1.2,

Thanks in advance for the help.

Update: I tested my camera in lightroom yesterday and everything worked perfectly so this has to be some type of darktable bug…

gphoto bug probably.

What does one do to troubleshoot?

You could use something like Regshot to find any change after taking a photo.

@darix is there a way to re-install just the gphoto part of Darktable? If i understand it correctly its embedded right? (i.e. when i install DT it also installs gphoto…)

@Marctwo im not familiar with this, what would that allow me to do…try and understand whats happening in the software after i take a photo and it tries to transmit to DT?

Thx.

I start off thinking simple. So my first thoughts are of the session options in the preferences.

With Regshot, you’d get to the point where you’re ready to take a photo then you take a snapshot of your system using regshot. The you take the photo and take a second snapshot of your system. You then compare both snapshots showing any changes that occurred between the two.

Got it! Thanks for the explanation. I will download that and give it a try.

So regshot keeps crashing when i try to run the 1st shot. Should I point this towards a certain directory or file? It seems like it is getting overwhelmed when it scans all of windows…

Also here is what the session options look like in preferences on DT

image

In the base directory try either double backslashes (C:\\Users…) or single forward slashes (C:/Users…).

For regshot, set it to scan the whole drive C:. It can take a while for the first scan but I’ve never had it crash on me so can’t advise about that.

sorry it didnt crash it just took forever (5min or so). Its working now…standby for results.

Okay here is the file…ignore all the google chrome changes. I couldn’t help but do some work while it was loading.

Thoughts? Regshot_5-22-19.txt (106.0 KB)

So I just re-read this and realized you were talking about the settings in Darktable not in Regshot. I just changed the base directory naming as you suggested and its working now!!! :slight_smile: :slight_smile: Images are transmitting and capturing!

For my knowledge can you advise what that change actually did?

Also, one thing that i noticed is that the images are only capturing on the computer and not on the memory card…is there a way that it can capture on both?

Thank you so much for all the help! This is a huge relief.

The double backslashes is a coding thing and shouldn’t really be relevant to the user… so I guess it’s a bug.

As for saving to card as well… I can’t help I’m afraid. I remember seeing the question asked here quite recently but I don’t recall if a solution was found.

No worries this is still hugely helpful! If i wanted to save the captured folders to a different location, could i do this with that same thinking? i.e. use the double backslashes to save to a different folder on the c drive?

Yeah, I have found it a bit quirky to set up but now you know about the backslashes you should be able to get what you’re after.

1 Like