Preview image all green and black?

This is probably a stupid question, but I can’t figure it out on my own, so please help me.

My preview image is looking all green and black and simplified. I think it must be some kind of mask or something. I have tried to press all the buttons of the program to get rid of it and see the actual photo, but nothing helps. Also restarting the program won’t help.

@Tiina have you used Rawtherapee before and did it work correctly at that time?
It looks like your image opens with no demosaicing applied. Maybe you played with the demosaicing options in preferences, and now images open by default with no demosaicing?

Check in the Raw tab (Alt+r) if the demosaicing is set to “none”, if so select the most appropriate demosaincing algorithm (Amaze for exemple).

Could also be wrong white balance (disabled or 1/1/1).

Thanks for trying, I checked and demosaicing is set to amaze. The program was working perfectly last time I used it.

White balance is also not the problem. Any other ideas?

What’s your camera’s make and model and which RT version are you running? I think it’s time for you to share one of your problematic raw files (upload to http://filebin.net) so we can try to replicate the issue.

This is how it looks: http://filebin.net/ontf8lsp8u/green.jpg. I think it is rather program problem(some setting I used unintentionally), not the RAW files. I worked with the same files previously and they were just fine then.

Have you tried to set the processing profile to Neutral?

To the left of the processing profile selector is a button, we call it the “fill mode” button. Click it to set it to “fill” mode. In your screenshot it is in “Preserve” mode. Then select the (Neutral) profile and report back if the green is gone.
http://rawpedia.rawtherapee.com/The_Image_Editor_Tab#Processing_Profile_Selector

If it did not work, upload the raw file, the pp3 file and the “options” file using http://filebin.net/ and paste the full link here.

Thank you all for trying to help me. The solution was to go to Raw tab - Dark frame and choose Auto selection. I have no idea why this happened to one whole picture folder but now I am happy to continue working with these pictures.

Hi, i installed the 5.8 version of RT on Win10 & i am facing a similar problem. The Cr2 file (Canon 60D) looks ok in the thumbnail view, once i open on the editor, the image turns black and green. This happens to all raw files & not jpg files. can you help on this

Maybe it is related to this problem?

1 Like

thank you for sharing, it seems like an problem with version 5.8 for Canon RAW files. i had installed 5.7 now & it works perfectly fine now

1 Like

Installed version 5.7 of RT & it works now

No, it’s a problem for Canon mRaw and sRaw files, which are not raw, because they are already demosaiced. With real raw CR2 files, there is no problem.

Edit: for reference
https://cpn.canon-europe.com/content/education/infobank/image_compression/file_types_raw_sraw_and_jpeg.do

1 Like