Problems with CR3 from Canon EOS R7 in RawTherapee 5.9


to the first, my english is not good. Sorry for that :see_no_evil:

I have a new Canon EOS R7 and the RAW and CRAW doesn’t show correct in the editor.
When I start RawTherapee and go to the directory with my fotos, they displayed in the Fileexplorer correct. See here:

But in the editor the picture is displayed so:
The picture showed pale and on the left side and on the top is a black frame

The IrfanView displayed the RAW correct, but here I cannot make RAW editing.
I tested both RAW from Canon. The uncompressed RAW and the compressed CRAW. The same error.

I hope you understand my problem and can help me.
I use a Windows PC with Windows 10 Pro 64-bit and RawTherapee 5.9

Many thanks

Abends, @Matthias82, and welcome!

More info here:

Also use the forum’s search facility:

Claes in Lund, Schweden

Thank you for the information, but my experience to program is near zero.

Mfg from Germany

If you supply a sample image I can test on my Windows 10 computer.

Both issues are known. The crop issue will be solved in the next release, or if you use a nightly build:

Please know that metadata support for CR3 files is not yet possible. This will have to wait until a bit later.


Thanks for the quick response!