Problems with Shadertoy

I try to use shadertoy with an image, but it doesn’t work. Error: Can not render: glGetString(GL_VERSION) failed.

To receive any kind of help, you need to provide more info.

  • What exactly are you trying to do (project file and/or screenshots) ?
  • What should the result be ?
  • Which OS, what GPU, Natron Version ?

Otherwise there is no chance to get any answers…

1 Like

Version: 2.3.14
Trying to run an image into Shadertoy to give it an effect
Windows 10, integrated (laptop)
It’s that run into a merge node
Keyer for transparent background

this is what the code do: glGetString - OpenGL 4 Reference Pages

this is what i find: Redirecting...

you also need to update your graphic driver.

Can’t update drivers.

GL errors are mostly because Natron can’t recognize your graphics driver properly.
To solve it, you can try two things:

  1. Reinstall Natron; that might fix it.
  2. Reinstall/update graphics driver; That should most likely fix it.

If you can’t update your graphics driver, you can try disabling this option in the shadertoy node:
I think that option is pretty self explanatory.

I had similar problem. To fix I had to enable GPU (It was default off), BUT I also had to increase “openGL contexts”

1 Like

I’m pretty sure this is a Natron problem. I have a system with an NVidia RTX in it, which works fine with every other OpenGL application on the planet (that I’ve tried), but I’m having this same issue.

I may try and take a look at this at some point, but I’m fairly sure this is a Natron issue (or a problem with the Shadertoy plugin)… but I suspect it’s not a problem with the system.

I did uncheck the GPU rendering tickbox, and the Shadertoy plugins seem to be working fine now.

1 Like

This is a Windows specific issue, Shadertoy/GPU works fine on Linux (as long as you have proper driver) and macOS.

This is the only workaround for the moment.

1 Like


I also had the same problem. First I turned off the GPU renderer but then I realise that my image/video (tested it for image & video) didn’t have the same fps of my project. My project had 30 fps. My image/video had 25 fps. I checked custom fps and set the fps of my image/video to 30 fps. Since then it’s working fine.

Regards PixlyPixels.

P.S. If that’s not working: recreate the project. That also worked for me.