problems with watermarks in darktable 4.2

My watermarks are no longer pulling into darktable. I’ve removed and added the watermarks folder back into the .config file but so far no luck. Anyone know how to solve this problem?

Hi, I’m experiencing the same problem. My custom watermarks were available in 4.2 but after updating to 4.2.1 the .config/darktable/watermarks folder disappeared. I re-made it with the same path and images as before but they won’t show as options within the module dropdown menu. Has the location for the watermarks folder changed?

edit: I am running Linux Mint 21.1, and the new and previous packages were installed from flathub.

That’s not dt issue as there is no clean-up done by darktable. Maybe during the upgrade something related to you distro?


I’ve replaced the folder with the same path as before (as stipulated in the DT manual) yet the module does not see the images in the folder. Any suggestions as to what to do?

No idea, and it seems that this is working for others otherwise we would have more reports about this. Just tested on master & 4.2.0 and all is working for me. I don’t have 4.2.1 ready to test.

re-installing Darktable from the flathub package has not solved this issue. The install process does not create a .config/darktable folder.

Yes it should preserve the watermarks. The installation process does not change anything in $HOME/.config/darktable. If there is something changed here then it is a distro issue but not darktable.

Oh flatpak!

The location of files for flatpak is different. Check:


1 Like

Ahhh this has solved everything, thank you! How strange that the previous version from flatpak worked, but this latest update broke somehow.