Processing noise reduction and display update preview


#1

I find a bit slow when processing with noise reduction enabled. What I usually do is disable the noise reduction modules while adjusting other modules and then enable it again before exporting. Could this be done automatically when working? For example, process all modules except noise reduction, update the display, and then continue processing the noise reduction and update the image display again. This could result in better feedback while working, instead of waiting to all modules to finish. Maybe it could be an option at least. Or maybe I need a better GPU :wink:


(Mica) #2

Yup. Or just make noise reduction the last step in your workflow.


(Daniel Catalina) #3

I have created a style that applies the modules with more computational needs and apply it before export.

Have a look here: https://www.darktable.org/usermanual/en/export_selected.html

I do not use style option from here because noise reduction is something you need to personalize for each image. But other modules can be put into a style and applied here.


(Christian Kanzian) #4

It is not automatically, but you could assign a shortcut to turn on/off the module.

I guess you are using NLM in profiled denoise and maybe a Nvidia GPU?
If you can avoid NLM it would be faster I guess.

Maybe you can use some technique to avoid NLM and use wavelets. @rawfiner made a nice video tutorial about noise reduction:

https://discuss.pixls.us/t/video-tutorial-about-noise-reduction-with-darktable-2-6/


#5

I’ve just tried to disable OpenCL support from core options… and everything is faster
It wasn’t using the NVIDIA 960 card, but the integrated intel graphics. I’ve tried with all default, multiple GPU and Very fast GPU options… none work… the graph usage of CPU in windows task manager moves on the integrated GPU, but not NVIDIA. I’ve tried to setup darktable.exe to use NVIDIA from the NVIDIA control panel but it doesn’t seem to work… Maybe it is another exe that has to be configured there?


#6

it doesn’t work when having two instances of noise reduction (one for luma and one for chroma) Only one is enabled/disabled
thanks for the tutorial :slight_smile: