Purple dng rendering


(Nik) #1

I am having RT rendering purple dng files. Processing profile is on Neutral, so no processing applied.
The original ARW looks fine

DNG can be downloaded from here


(Nik) #2

Has anyone any idea of why this is happening? I still get all my DNG images rendered with purple cast…


(Morgan Hardwood) #3

Upload the original raw file of a different shot, not the one from above.
Use https://filebin.net/ if you can’t attach directly.


(Nik) #4

here new dng

same problem:


(Ingo Weyrich) #5

Please post the content of AboutThisBuild.txt. Currently we don’t know which version of RT you are using


(Nik) #6

I have used the following builds. Same problem with all of them:

Version: 5.4-795-g6f6cdd113
Branch: dev
Commit: 6f6cdd113
Commit date: 2018-09-05
Compiler: gcc 8.2.0
Processor: generic x86
System: Windows
Bit depth: 64 bits
Gtkmm: V3.22.2
Lensfun: V0.3.2.0
Build type: release
Build flags: -m64 -mwin32 -msse2 -mfpmath=sse -mthreads -Wno-aggressive-loop-optimizations -Wno-parentheses -std=c++11 -mtune=generic -Werror=unused-label -fopenmp -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -DNDEBUG -O3
Link flags: -m64 -mthreads -static-libgcc -mtune=generic -s -O3 -fno-use-linker-plugin
OpenMP support: ON
MMAP support: ON

Version: 5.4-872-g260d7fadf
Branch: dev
Commit: 260d7fadf
Commit date: 2018-09-18
Compiler: gcc 8.2.0
Processor: generic x86
System: Windows
Bit depth: 64 bits
Gtkmm: V3.22.2
Lensfun: V0.3.2.0
Build type: release
Build flags: -Wno-parentheses -std=c++11 -mtune=generic -Werror=unused-label -fopenmp -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -Wno-aggressive-loop-optimizations -DNDEBUG -O3 -ftree-vectorize
Link flags: -m64 -mthreads -static-libgcc -mtune=generic -s -O3
OpenMP support: ON
MMAP support: ON

Version: 5.4
Branch: 5.4
Commit: a5e8eb9c8
Commit date: 2018-03-20
Compiler: gcc 7.3.0
Processor: generic x86
System: Windows
Bit depth: 64 bits
Gtkmm: V3.22.0
Lensfun: V0.3.2.0
Build type: release
Build flags: -m64 -mwin32 -mthreads -Wno-aggressive-loop-optimizations -std=c++11 -mtune=generic -Werror=unused-label -fopenmp -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -DNDEBUG -O3
Link flags: -m64 -mthreads -static-libgcc -mtune=generic -s -O3 -fno-use-linker-plugin
OpenMP support: ON
MMAP support: ON

Version: 5.4-795-g6f6cdd113
Branch: dev
Commit: 6f6cdd113
Commit date: 2018-09-05
Compiler: gcc 8.2.0
Processor: generic x86
System: Windows
Bit depth: 64 bits
Gtkmm: V3.22.2
Lensfun: V0.3.2.0
Build type: release
Build flags: -m64 -mwin32 -msse2 -mfpmath=sse -mthreads -Wno-aggressive-loop-optimizations -Wno-parentheses -std=c++11 -mtune=generic -Werror=unused-label -fopenmp -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -DNDEBUG -O3
Link flags: -m64 -mthreads -static-libgcc -mtune=generic -s -O3 -fno-use-linker-plugin
OpenMP support: ON
MMAP support: ON


(Ingo Weyrich) #7

The files (well, I tested only one of them _DSC2827.DNG) show in metadata that they are produced by adobe lightroom classic 7.5 (Windows). Don’t know what lr did to that files…


(Nik) #8

that’s exact. I converted my original ARW to DNG in Lightroom

But it’s the same with Adobe DNG Converter (10.5)


(Mica) #9

RawTherapee will work with the original ARW file, no?


(Nik) #10

yes


(Morgan Hardwood) #11

@niccoc1603 thank you but I asked for the original raw file, not for the DNG.


(Nik) #12

I see, I have uploaded the ARW files now


(Roel) #13

At least there seems to be nothing wrong with the ARW’s. RT renders them fine.
For the DNG’s the red and blue black points seem out of whack…


(Morgan Hardwood) #14

Your DNGs are purple because you have enabled “Embed Fast Load Data” when converting the ARWs to DNGs. Turn that off and things are fine.


(Nik) #15

THANK YOU! everything looks fine now