Que not working - will not save developed

I have been using ART 1.2 and like it very much. Suddenly, it stopped developing photos - reporting a “File Save Error”. I replaced it with 1.4 but same problem. RT 5.8 still works, just fine.

Any help will be appreciated. Thanks.

Hi, can you post a screenshot of your queue tab? Also, did you try 1.4.1? Thanks!

I had this problem too a while back. If I remember rightly I think the problem was with files that I had also edited it darktable so they also had an xmp file. I think I solved it by changing the settings so that ART didn’t read or write data to xmp files. Keeping darktable files in different folders was the easiest solution.
I might be completely wrong, so sorry if I have sent you down the wrong path, but I think this may have been what helped.

Sorry… I should have been more specific. Yes I was using 1.4.1, downloaded this morning. I also apologize for mis-spelling Queue. My mind can spell it, but apparently my fingers cannot.

The screen shot is here: http://look.furnfeather.ca/ART_1.4.1.html

Re: spidermonkey’s comment, the first shot (of a wooden gate) had not been developed in any other program. However after that, I tried it in Raw Therapee and it worked just fine.

Below the screen shot of the queue is a shot of the sidecar files, in case that helps.

I have tried it with the Queue both ON and OFF and with the Auto-start checked and unchecked. It seems to make no difference. When I click on the gears, to develop the shot, the gear appears in the thumbnail, but the little “diskette” that indicates the file has been “developed” never appears, even after 15 to 20 minutes, and no jpg file is produced.

David.

Call off the dogs! As an experiment, I took another photo not previously developed, and added it to the cueue. The entire queue then developed as it normally would and the problem is solved. But, I have no idea why! When the cueue was working, the ON button displayed in blue, and when it was finished, it went off, and the off was again grayed out.

For what it’s worth, the problem appeared in 1.2. I had made no changes to any settings in 1.2 and it had worked before, flawlessly. It was only then that I downloaded 1.4.1 in order to see if there had been a bug fix. But, 1.4.1 was the same, until just now. Again, I had changed no settings from those seen on the screen shot.

Thank you, aggrigio and spidermonkey for your efforts. I am at a loss to explain what has gone on.

David.

OK so I was leading you down the wrong path. Hope it is sorted now but would be good to know what the cause is.

Did you make sure you have write permissions for the output directory?

Good Morning. It is a one user, Win10 computer, and I am the admin, so I assume I have “write permissions”. Certainly, I did not change any permissions, or, for that matter, anything. I just made sure I had another file that had not previously been developed, told ART to develop it, and away it went. Absolutely no idea why 1.2 would stop, or 1.4.1 would suddenly restart.

BTW: lest you think I am completely crazy, I’ve been building/using computers since 1976. Now, at age 73, I am no longer completely up to date, but I can still handle the basics.

If it works, I’m happy, as ART seems to be a very nice alterantive to RT. Thank you, once again, for your time & trouble.

David.

Hi,

Sorry, I didn’t mean to insult you – I was just trying to rule out the obvious things. Unfortunately I don’t have a pc with me so I can’t debug things right now

Do not fear. You did not offend. I was only trying to let you know the now limited skill set you are dealing with. This is obviously a bug and if you wish to try to determine the cause so it can be fixed, I am more than willing to help, if I can.

Best regards. David.

The problem has occurred again. I added a photo taken only minutes before, never developed in any other software, to the queue. And that’s the end of it. I cannot make the software develop the image.

I can, of course, develop it in RT, but I’m getting to very much like ART, other than this problem.

Any help will be greatly appreciated.

David.

Sorry… uploaded the wrong image… but even with AutoStart checked, it does not start.

Hi,
Is the on/off switch not functioning? What happens if you click it? What kind of error message do you get?

Thanks!

Hi. It does not matter if the Auto-start box is checked, or not. This time, if I click on the greyed out OFF button, nothing happens. If I click left of it, where the ON button should show (at least when working), nothing happens. Clicking on the Profile box also does nothing. Quite frustrating.

I am not in front of my computer now, so I can’t try things out…I will get back as soon as I can

Hello, I managed to repeat your problem twice (things greyed out, no development) - but only twice! Your dng resides in F:/, please copy that one to your desktop and put it from there in the queue. Does that change anything?

OK,. To start, I added an image to the queue,


Everything stayed greyed out, so I deleted one image from the queue, and nothing changed. But when I then used the left right arrows, to change the order in the queue, the blue ON square lit up, as you can see in the upload. However, still nothing developed. I then copied a file to the desktop, and used ART 1.4.1 from there. When I added it to the queue, the ON square went out, and everything reverted to as before. No development.

The problem is intermittent … sometimes the queue works, and other times not. In all cases, these same files are readily developed (later) by RT.

Hello, my uneducated guess is that half of this problem resides at you (your system, your house, the cat), and the other half in ART. For the moment I don’t have a clue to help you further, perhaps others have brighter minds…

I may be laying another false trail here, but I recently had a problem with ART not saving pictures, then found that my Antivrus programme (AVAST) had suddenly decided that ART wasn’t allowed to write to files (the joy of Windows). I had to go into antivirus programme and add ART to my list of allowed programmes. I had similar issues with other software.

I may be wrong, but might worth checking…

1 Like

Spidermonkey, you are BRILLIANT! Like you, I use AVAST, and as soon as I created an exception for ART, the program started developing files in the queue! I then put more files in the queue and it worked, every time!

Why there should be such a conflict with AVAST, when RT has no similar problem, I don’t know - but really, I don’t care, so long as it works. Thank you, kindly, for this insight!

And thank you to all who helped with this problem.

Best regards, to you all.

David.