Rapid Photo Downloader 0.9.13 error, exited

I was very pleased to read of Damon Lynch’s app on Linux Mint Forum
https://forums.linuxmint.com/viewtopic.php?f=206&t=288423&p=1599001#p1598991

I tried twice tonight to get it to install, and it aborted twice.

Maybe the Internet is just too busy at the moment?
Tnx for any thoughts you might have on this?
John Craig
Oologah, Oklahoma

Following is my PC’s info, and the last few lines from Terminal:

author: damon lynch

I tried twice to install Rapid * * program.

got this error and it stopped:

Downloading https://files.pythonhosted.org/packages/01/8c/eeff014306fcdbb8afda0fe603d1b458dddf2be0ca10d561b0015e439357/PyQt5-5.12-5.12.1_a-cp35.cp36.cp37.cp38-abi3-manylinux1_x86_64.whl (61.1MB) Collecting PyQt5_sip Received error code 2 Failed to install application requirements: exiting john@john-TP500LA ~/Downloads/Rapid Photo Downloader $

$ inxi -Fxz System: Host: john-TP500LA Kernel: 4.15.0-45-generic x86_64 (64 bit gcc: 5.4.0) Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia Machine: System: ASUSTeK (portable) product: TP500LA v: 1.0 Mobo: ASUSTeK model: TP500LA v: 1.0 Bios: American Megatrends v: TP500LA.203 date: 06/11/2014 CPU: Dual core Intel Core i3-4030U (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7582 clock speeds: max: 1800 MHz 1: 828 MHz 2: 1464 MHz 3: 1320 MHz 4: 1479 MHz Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0 Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1360x768@59.80hz GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes Audio: Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 Sound: Advanced Linux Sound Architecture v: k4.15.0-45-generic Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.1 IF: enp2s0f1 state: down mac: <filter> Card-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter driver: mt7630e v: 2.3.8 2.3.8 2.3.8 2.3.8 2.3.8 2.3.8 bus-ID: 03:00.0 IF: wlp3s0f0 state: up mac: <filter> Drives: HDD Total Size: 500.1GB (59.6% used) ID-1: /dev/sda model: Samsung_SSD_860 size: 500.1GB Partition: ID-1: / size: 28G used: 14G (51%) fs: ext4 dev: /dev/sda1 ID-2: /home size: 164G used: 116G (75%) fs: ext4 dev: /dev/sda5 RAID: No RAID devices: /proc/mdstat, md_mod kernel module present Sensors: System Temperatures: cpu: 39.0C mobo: N/A Fan Speeds (in rpm): cpu: 2600 Info: Processes: 201 Uptime: 14 min Memory: 979.0/11875.0MB Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.481) inxi: 2.2.35 john@john-TP500LA ~/Downloads/Rapid Photo Downloader $

Do this from the terminal. Do not use sudo:

pip3 install --user --verbose PyQt5

Adding the verbose command line switch should provide more information as to what is going wrong.

Got a whole series of “Skipped links” will post the 2 last ones.
Is Rapid Photo Downloader supposed to be in the Menu? if so, it is not.

the forum is not allowing me to post the Terminal links in full, so I have stripped out https:// and replaced it with …


Skipping link…files.pythonhosted.org/packages/32/73/ef5dc9cc37c132b705afd58aaf4ef7db8036849a53cb35ce45d864d96117/PyQt5_sip-4.19.14-cp37-none-win32.whl#sha256=40504f96ecb834e54491ead558589bfd773056dba7f2df76599a06fdd8ed1ead (from…pypi.org/simple/pyqt5-sip/); it is not compatible with this Python
Skipping link…files.pythonhosted.org/packages/e4/e5/5e9462008239783720c3eb81d73d2101cc2d5666c2e4db40fe594071d8a7/PyQt5_sip-4.19.14-cp37-none-win_amd64.whl#sha256=6b65d2b14084eb583bf4cf68b97ade295fabae5f5bf2aae0ab00ab30533f1c60 (from https://pypi.org/simple/pyqt5-sip/); it is not compatible with this Python
Using version 4.19.14 (newest of versions: 4.19.14)
Using cached …files.pythonhosted.org/packages/0a/b0/ae36db5015cae2215fc5f6ac95670f920901601c19f39fcf2e55ef0e8b9b/PyQt5_sip-4.19.14-cp35-cp35m-manylinux1_x86_64.whl
Downloading from URL …files.pythonhosted.org/packages/0a/b0/ae36db5015cae2215fc5f6ac95670f920901601c19f39fcf2e55ef0e8b9b/PyQt5_sip-4.19.14-cp35-cp35m-manylinux1_x86_64.whl#sha256=058d450c26be92193605f4628ff690d77080f599ffe381a1029cea8eeb71ab8e (from https://pypi.org/simple/pyqt5-sip/)
Installing collected packages: PyQt5-sip, PyQt5

changing mode of /home/john/.local/bin/pyuic5 to 775
changing mode of /home/john/.local/bin/pyrcc5 to 775
changing mode of /home/john/.local/bin/pylupdate5 to 775
Successfully installed PyQt5-5.12 PyQt5-sip-4.19.14

I have tested it in my copy of Linux Mint 18.3 that I use for testing in a virtual machine. It seems the primary problem is that the version of the python installer, called pip, that is in Mint 18.3 is by now horribly out of date and is not working properly.

So do this, to fix the situation:

python3 -m pip install --user -U pip

and then run the installer again:

python3 install.py

Let us know how you get on.

1 Like