Rapid Photo Downloader 0.9.20 is released

I put the SD card from the camera in my computer. This starts up RPD. Normally it shows the photo’s on the card, and knows which photo’s are new since the last download. I can then proceed to download just the new images from the card to the computer. It now tells me the timeline is corrupt, and I let it generate a new one, as it suggested. This took a while, and when it was ready RPD told all 2400 images on the card were new (in reality, only about 60).

Screenshot attached (this one is probably an OS problem…). I went to bugs.launchpad, but it wanted me to create an account, and I didn’t want to do that.

In that case, I need to say thanks for letting me know — but I won’t be taking this any further.

If you want problems with Rapid Photo Downloader fixed, and I request additional information like log files, then you’ll need to open a bug report, or multiple reports in case of multiple problems. That means opening an account on launchpad if you don’t already have one.

I understand, I will open an account :slight_smile:

Hello
With Archlinux, and Python 3.8 RPD don’t work :
$ rapid-photo-downloader
Traceback (most recent call last):
File “/usr/bin/rapid-photo-downloader”, line 6, in
from pkg_resources import load_entry_point
File “/usr/lib/python3.8/site-packages/pkg_resources/init.py”, line 3259, in
def _initialize_master_working_set():
File “/usr/lib/python3.8/site-packages/pkg_resources/init.py”, line 3242, in _call_aside
f(*args, **kwargs)
File “/usr/lib/python3.8/site-packages/pkg_resources/init.py”, line 3271, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File “/usr/lib/python3.8/site-packages/pkg_resources/init.py”, line 584, in _build_master
ws.require(requires)
File “/usr/lib/python3.8/site-packages/pkg_resources/init.py”, line 901, in require
needed = self.resolve(parse_requirements(requirements))
File “/usr/lib/python3.8/site-packages/pkg_resources/init.py”, line 787, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The ‘babel’ distribution was not found and is required by rapid-photo-downloader

for now this is not a problem due to the containment ! no picture !

See:
https://bugs.archlinux.org/task/66090?opened=32440&status[0]=
https://bugs.archlinux.org/task/66089?opened=32440&status[0]=

updated a few hours ago by Archlinux.
works fine again. Thank you.