Rapid Photo Downloader does not work on Fedora 33

I tried to use Rapid Photo Downloader on Fedora 33, but it won’t start. I used Rapid Photo Downloader installer 0.3.8 to install it with python3 install.py . When I try to start the program I get:

$ rapid-photo-downloader 
**
ERROR:../gi/gimodule.c:1826:_wrap_pyg_hook_up_vfunc_implementation: assertion failed: (G_TYPE_IS_CLASSED (implementor_gtype))
Bail out! ERROR:../gi/gimodule.c:1826:_wrap_pyg_hook_up_vfunc_implementation: assertion failed: (G_TYPE_IS_CLASSED (implementor_gtype))
Aborted (core dumped)

Any ideas how to solve the issue?

1 Like

I also had problems with RPD though not on Fedora. Maybe this helps: install qt5ct and choose a different theme for qt5.

Thanks for tips. But it didn’t solve my problem :confused:

Just looked it up - there should be a version of RPD in the Fedora 33 repo - maybe you should use that?

I’ve never seen this problem before and I’ll need to investigate it further. It’s related to Gnome’s gobject introspection.

I’m pleased to see Fedora has packaged Rapid Photo Downloader 0.9.24 on Fedora 33. However when I launched the Fedora packaged Rapid Photo Downloader, the threading module in Python 3.9 threw exceptions (which is bad). I’ve not tested Rapid Photo Downloader with Python 3.9 myself, so I can’t say if this problem is unique to Rapid Photo Downloader or indicative of a wider problem with the current release of Python 3.9 in Fedora 33.

So as of today, unfortunately Rapid Photo Downloader will not run properly on Fedora 33.

I had a very similar error message, also Fedora 33.
Turned out it was caused by unity libraries I didn’t need anyway.
Solved it with:
sudo dnf remove python3-libunity

1 Like

Did you install Rapid Photo Downloader using dnf or my install.py script?

Altered between dnf and setup.sh while testing.
Hm, just retried setup.py. It correctly removed the (working) dnf RDP. But also:

Installing : dee-1.2.7-32.fc33.x86_64
Installing : libunity-7.1.4-23.20190319.fc33.x86_64
Installing : python3-libunity-7.1.4-23.20190319.fc33.x86_64

and I again get
**
ERROR:…/gi/gimodule.c:1826:_wrap_pyg_hook_up_vfunc_implementation: assertion failed: (G_TYPE_IS_CLASSED (implementor_gtype))
Bail out! ERROR:…/gi/gimodule.c:1826:_wrap_pyg_hook_up_vfunc_implementation: assertion failed: (G_TYPE_IS_CLASSED (implementor_gtype))
[1] 6189 IOT instruction (core dumped) rapid-photo-downloader

So run: sudo dnf remove python3-libunity
and it removes all those and RPD starts again.

Btw, thank you for RPD, appreciated!

1 Like

Personally I wouldn’t run Rapid Photo Downloader on Fedora 33 for now, because of these threading errors:

Exception ignored in: <function _after_fork at 0x7f3db2f53040>

Traceback (most recent call last):

  File "/usr/lib64/python3.9/threading.py", line 1486, in _after_fork

    thread._reset_internal_locks(True)

  File "/usr/lib64/python3.9/threading.py", line 829, in _reset_internal_locks

    self._tstate_lock._at_fork_reinit()

AttributeError: 'NoneType' object has no attribute '_at_fork_reinit'

This is the first time I’ve seen a problem manifest like this in a core Python system library. It’s not good.

My solution for now is to use a virtual machine, with Fedora 32, on Fedora 33.

Sounds sensible. I’ll put out some feelers to see if any other developers using PyQt5 have noticed anything like this threading issue happening on Fedora 33 / Python 3.9.

Happen to have figured anything out about this? I just upgraded to Fedora 33 today and found this out.

I don’t think so but help is certainly welcome!

Hmm, well installing in a virtual env seems to work. Guess I’ll stick with that for now.

It works in Fedora 33 now. See https://damonlynch.net/rapid/download.html for download. On that page there is a link to install.py (https://launchpad.net/rapid/pyqt/0.9.26/+download/install.py) file. Download and execute with “python3 install.py” on Fedora33.

Start the program with “rapid-photo-downloader” in terminal, or find the icon in GNOME menu.