RawTherapee 5.3 Released


(Morgan Hardwood) #1

We have just released RawTherapee 5.3!

http://rawtherapee.com/blog/rawtherapee-5.3-released


Feature request: save as floating-point
(Christian Malchus) #2

Just had it installed to my Ubuntu OS.
First tests look GREAT - and I think I’ll be busy testing the various features the next days / evenings!

To put it short: thank you!!! :grinning::+1:


(Rick Davis) #3

Long time user, it just keeps getting better and better. Thanks to all the developers for their hard work.


#4

I’m using RT since one year with my Panasonic GX80. The lens information support added for Panasonic cameras in RT 5.1 and now the integration of lensfun. Great! Thanks a lot for all the effort.


#5

Looks professional and a little bit overwhelming in possibilities! That is good and complicated! :slight_smile:

Although I tried older versions of RT in the past, the 5.3 release looks like a more mature product.
BUT… I’m running it on rather heavy Win 10/64bit Pro machine I use a lot for photographic post processing. With s/w like Nikon ViewNX-i (my original RAW converter), lots of pano stitching with PTGui Pro and PS CC 2017 for more common PP.
(No, I hate LR because of the database dependencies)
The real ‘but’ I have with RT 5.3 is its lack of speed, sorry to say.
My machine is a i7 980x CPU running @ 4GHz, 24 GB RAM, 3 x SSDs for OS, scratch and swap disks. And several TB’s of HDD for image storage + R9 270x graphical card for GPU acceleration with PS CC and PTGui.

RT 5.3 takes a long time to start, almost 50 seconds or more and e.g. clicking on the ‘preferences’ button adds another 30 seconds wait. And a few seconds after I click on ‘preferences’, the rawtherapee.exe PID gets status ‘not responding’. (?) while the rest of my computer is idling…
And yes, I’ve already tried reinstalling RT 5.3, clearing its cache directory; but to no avail. Even starting in a empty directory.
When RT 5.3 is starting up, there is hardly any activity to see in the Resource Monitor. only 2-3 % CPU util, very low disk I/O, hardly any network I/O, and lots and lots of memory not used.
So what is RT 5.3 doing, what is taking so long??? Any ideas? Even starting up PS CC 2017 with a 2GB TIFF file goes faster

What might be going on?
Because this way it’s almost impossible to explore the RT 5.3 capabilities.


(Sebastien Guyader) #6

First thing to check, I think, is whether floppy disk support is enabled in your machine’s bios. If so, disable it. Second, if you have any network drive connected, try disconnecting it.
Third, delete the options file.

RT is not slow per se, on my old laptop (3.2 GHz i5 2520M CPU, 4 GB RAM, regular HDD) RT starts and is operational in less than 15 seconds.


(Alberto) #7

I suspect there is something in Windows 10 that doesn’t play nicely with RT. I’ve seen one more user complaining about this, and he was also on win 10. I think none of the ‘regular’ devs use it, so it might have gone unnoticed. just to confirm that, you can try running it in a Linux VM and see if that helps. even on my ancient ThinkPad from 2009 RT starts in about 10 secs and is generally very responsive…


#8

And that is present only on some W10 installations.
problems already encountered:

  • floppy disk enabled in BIOS
  • locale and UTF8 conversion
  • the annoying error boxes (solved by SetErrorMode (SEM_FAILCRITICALERRORS | SEM_NOGPFAULTERRORBOX | SEM_NOOPENFILEERRORBOX in main.cc);
  • network drives
    -…

Here I have Intel core i7-6700K, 16GB, 3 local drives, NAS connected with 2 drives.
The start time is about 2s.
If I can help don’t hesitate to ask.


#9

Windows 10 Pro, Version 1703 Build 15063.608

Thanks for the suggestions.
-I had already found those remarks about FDD BIOS settings. Sounds very weird to me, that it should have any impact on the performance and/or idle wait of software like RT :thinking: (30 years ago I would save my programs on 8" FDD drives :grinning:) But no, there is no A: (or other unused FDD) drive enabled in the BIOS of my machine.
-Even with all networking facilities disabled (even no Internet connectivity), the issue remains. No network drives defined whatsoever.
-Deleting the C:\Users[user]\AppData\Local\RawTherapee\options file only results in RT (after the long wait) starting with its initial setup screen and default settings.

I’ve also tried reinstalling 5.2 version; same issue
Reinstalling 5.3 version; same issue
Installing/reinstalling with/without “Run as Adminstrator”; same issue

Checking the Event Viewer for specific error messages; no luck :disappointed: Nothing was logged during the time RT is waiting/idling (?) for something not happening…?

Even if RT 5.3 is finally running, the impact on the resources of my machine is marginal. Hardly a few % of CPU activity, no high disk I/O, vey reasonably memory usage (PS CC 2017 uses a lot more memory)


#10

Sorry, but setting up a VM, let alone be a Linux VM is not something for me. I don’t have the experiences/knowledge to do that.

What do you mean with the locale and UTF8 conversion setting? I’m running Win10 standard UK English, also RT 5.3 is UK English, with European (continental) date/currency/etc. settings.

? Is that something I can change, or are those settings for the people who compile RT? (not me, I presume?)

What about network drives?


(Flössie) #11

I hope (and think) we can exclude that. The msys2 std::regex hang is being worked around in 5.3. Other locale problems led to SEGVs.

AFAIK, this is already included, and no, you can only change it at compile time.


#12

@PanoMeister Sorry it was just intended for @agriggio or other devs to explicit its remark on past Windows problems and propose test help if needed.


(Alberto) #13

the first thing to do would be to isolate the problem, meaning:

  • confirm it happens only on win10
  • identify if there’s any common hardware involved
  • check other gtk apps and see if similar issues arise
  • verify that rawtherapee-cli is not affected

unfortunately I don’t have a win10 installation so I won’t be able to perform any of the above tests…


(Rick Davis) #14

5.3 opens a little faster than 5.2 on my computer. Takes about 7 seconds as compared to 9 before. My computer is a Windows 10/pro/64 with an i5 with 8 gbs ram. It is up to date with the MS updates. When I moved from W7 to 10 I noticed a slight increase in loading RT, but it was only a couple of seconds.


(Mica) #15

Are you running an anti virus? If so, fan you explicitly white list RT?


#16

With or without AV s/w enabled doesn’t make any difference… Also disabling firewall doesn’t make any difference…

The strange thing is; RT starts, but the computer simply doesn’t do anything. Hardly any CPU, Disk or memory activity. In the mean time (while waiting for RT to start), starting other programs is no problem at all! I can even fire up PS CC 2017 and several MS Office programs and browsers in the mean time. And then suddenly, after the almost 50 seconds wait, RT pops up. But when I do nothing, just staring at my screen, RT takes also 50 seconds…:thinking:

So it seems RT is waiting for something, but what? No events are logged in the event viewer.
Is there any way I can start RT in a kind of debug mode so that it writes a log file of what is doing, or better, what it is NOT doing?


(Mica) #17

You should obtain the debug version of RT and get a trace from GDB, I suspect.

I just had someone on reddit tell me it is slow on Win7x64 too…


#18

Launch time for RT 5.3 on my two PCs:
3.4 GHz i7 Win 10: 7 seconds
1.8 GHz i3 Win 8.1: 8 seconds


#19

I want that too. :yum: But how?


(Alberto) #20

Do you see the same issue also when using rawtherapee-cli (i.e. without starting the GUI)?