RawTherapee 5.8 not recognising lens correctly


For some reason 5.8 won’t recognize my Sony kit lens (E PZ 16-50mm F3.5-5-6 OSS) even though it’s clearly listed with the info above in the Exif data of the raw file. I believe this used to work in previous versions.

The info panel shows: SONY ILCE-6000 + Unknown (16-50mm f/3.5-5.6)

The lens also isn’t automatically selected in the Profiled Lens Correction. I can however select the lens manually from the list (named: Sony E PZ 16-50mm f/3.5-5.6 OSS).

Is this due to the slight mismatch in naming? is there a way to fix it?


What OS are you using?


I’m running on Windows 10.


I have had the same problem - with regard to the Automatic Profiled Lens slection - with the Sony 28-70mm OSS ‘kit’ lens. The LCP file for the lens is present in the folder, but the Automatic Profiled Lens selection doesn’t find the lens. :confused: When selected manually, the Profile Correction works properly. It just won’t auto-select the lens. The auto-select function does work, for my other lenses.

I see from the previous posts that someone asked which Operating System RT is running on. I don’t know whether this is relevant, but I’m running Windows 10.

Any suggestions, or solutions?

I’ve just checked, and I was wrong (in my previous post) to say that the auto-select function works for my other lens. Truth is - it doesn’t. :frowning_face:

No suggestions at all? Anyone?

There is no automatic selection of .lcp files. Automatic selection only works for lensfun profiles

If lensfun is not working for your cameras and lenses, then just use a single .pp3 for each of your lenses selecting the proper .lcp. And then use dynamic profiles to select the proper .pp3 … http://rawpedia.rawtherapee.com/Dynamic_processing_profiles

1 Like

Thanks @heckflosse and @chasingshadows for your replies. This is all new to me… I had no idea that automatic selection was limited to Lensfun profiles. In fact, although I had heard of Lensfun, I had no understanding of what it was. :blush:

I’ve just been reading the Lensfun site, and I see that my lenses are not listed under Supported Lenses, but they are listed in the “develop” section. It also said that Adobe profiles can be converted to Lensfun profiles using a script, but gave no information about how to do that. Since I already have the Adobe profiles for my lenses, conversion would be very handy, but I have no idea how to go about doing this.

Is anyone able to advise? TIA.

PS @chasingshadows… that link is giving a “500 internal server error” message. Any thoughts?

There is a conversion script in lenfun’s source code that does the conversion.

The link works fine here. Please try again. Dynamic profiles are a good way to automatically assign lcp files.

1 Like

Thanks, @heckflosse, the link worked fine when I tried it later. I’ve now set up the dynamic profiles, which are working well. The profile conversion option would have been the slightly ‘tidier’ solution, but since I would need tution at the ABC level :blush:, in order to be able to do that, I’ll probably stick with the dynamic profiles.

Thanks to all, for the replies. :+1:

Just a further question related to the topic of this thread… here’s a quote from the RT downloads page:

We found an issue with the original 5.8 Windows installer, it was missing the Profiled Lens Correction (Lensfun) database, so there is now a new installer from 2020-02-06 which includes this database. If you downloaded RawTherapee 5.8 for Windows previously, please download the new build and re-install.

Does the date quoted mean 2nd June, or 6th February? The date format tends to be used differently in the UK than it is in the US. Maybe someone could amend that page, to give the date in the numbers-and-words format, improving clarity.

Since I installed RT v5.8 in March, I don’t know whether my installation is the latest. The date of the latest installation might (or might not) be germane to my earlier question in this thread, but more importantly, amending the date stated in the downloads page, would make it clearer for readers, generally. TIA.


When in doubt, “download the new build and re-install”.

As for the missing lenses, it’s a known issue with no workaround that isn’t shit yet.

1 Like

The yyyy-mm-dd format is from the ISO 8601 standard, and one of its intents is to eliminate the ambiguity that occurs when some people write dates in dd/mm/yyyy and others write mm/dd/yyyy. And it comes pretty close to being universal. Very few countries support day before month when year is specified first, and neither the US nor the UK are on that short list.

1 Like

Ok, thanks @Morgan_Hardwood - I’ll re-install as you suggest.

Thanks @elGordo - that makes sense.

There still seems to be an issue with the repackaged version of RawTherapee 5.8 and it’s ability to recognize lenses.

I’m running Windows 10 Enterprise (build 1803).

This screenshot is from a fresh install of RawTherapee 5.7


Note it has correctly detected the lens and displays that in the main window and in the PLC section of the command windows

Now, I’ve uninstalled 5.7 and installed 5.8 - I’ve also deleted the PP3 files to make sure the directory is as it was. This version of 5.8 was downloaded today, 27th of July, 2020.

Per the screenshot, it is NOT detecting the lens correctly (same raw file):


However, it appears the profiles are there as I’m able to manually select and apply the profile and it does appear to work:

However, the lens remains unidentified in the main window, even though the profile is working:

Please note that the only changes I’ve made to these screenshots is to edit out the path as it includes my name, which I’d prefer remain private.

It appears to me that the issue is the actual detection of the lens; which a regression as it was working correction 5.7

The second screenshot is showing file metadata and selecting the lens profile for correction doesn’t change the file metadata.

Perhaps there is some problem with exiv2 in that build.

Understood, regarding that it doesn’t change the file metadata. But I guess the thing that I’m driving at is that something changed between 5.7 and 5.8 such that Rawtherapee is no longer able to detect any of the lenses that it previously could.

However, it doesn’t appear to be an issue with the Lensfun as shipped because the profiles are there and there is no issue with manually selecting them and applying them.

I understand it’s not the end of the world and I can work around it by manually selecting the appropriate profile but it used to work and it’s the kind of thing that probably should work out of the box.

Judging by the number of lens identification posts that popped up post 5.8; I’m pretty sure I’m not the only one with this issue.

Perhaps @heckflosse or @gaaned92 can help with windows troubleshooting.

As far as I know, this is the first that this particular problem has been reported.

I guess it is this problem:

Eagerly but patiently awaiting a cure :slight_smile: