rawtherapee-cli.exe does not process files

Hi Folks,

I have an issue processing files with rawtherapee-cli on windows.
I run the followiing command from the cmd:

start rawtherapee-cli.exe -o C:\Users\karsten\Pictures\Saved Pictures\Stack -Y -p C:\Program Files\RawTherapee\5.8\profiles\Pixel Shift\pixelshift_nomotion.pp3 -t16 -c C:\Users\karsten\Pictures\Zerene

rawtherapee opens the console for a very short moment, close it and nothing happens. All files in the folder remain unprocessed.

All referenced files and folders do exist.

Any tip what I am doing wrong?

Best regards,

As your path contains spaces you need to enclose the full path in quotes like “C:\Users\karsten\Pictures\Saved Pictures\Stack”

Hm, doesn’t seem to work.
I have eliminated all spaces from the pathes. Still the same, with or without quotes

No quotes
start rawtherapee-cli.exe -o C:\Users\karsten\Pictures\Stack -Y -p C:\Users\Pictures\zerene\pixelshift_nomotion.pp3 -t16 -c C:\Users\karsten\Pictures\Zerene\

Double quotes
start rawtherapee-cli.exe -o “C:\Users\karsten\Pictures\Stack” -Y -p “C:\Users\Pictures\zerene\pixelshift_nomotion.pp3” -t16 -c “C:\Users\karsten\Pictures\Zerene”

Single quotes
start rawtherapee-cli.exe -o ‘C:\Users\karsten\Pictures\Stack’ -Y -p ‘C:\Users\Pictures\zerene\pixelshift_nomotion.pp3’ -t16 -c ‘C:\Users\karsten\Pictures\Zerene’

dir C:\Users\karsten\Pictures\Zerene
20.03.2021 14:09 .
20.03.2021 14:09 …
02.02.2020 14:30 11.307 pixelshift_nomotion.pp3
20.03.2021 11:16 167.053.783 _K1_3576.PEF
2 Datei(en), 167.065.090 Bytes
2 Verzeichnis(se), 142.711.914.496 Bytes frei


what path you really are using?

C:\Users\karsten\Pictures\Saved Pictures\Stack

As @ChasingShadows proposed, the path including the spaces must be put between quotes.

“C:\Users\karsten\Pictures\Saved Pictures\Stack”

It wont help to eliminate the spaces, windows is a little bit picky at this point…

Well, I have just checked RawPedia Command-Line Options - RawPedia (rawtherapee.com) and I can’t find -t16. It is just -t

Morning Guys,

I’ve got it working finally.
This is the command that’s working:

start rawtherapee-cli.exe -o C:\Users\karsten\Pictures\Stack\ -Y -p C:\Users\karsten\Pictures\Zerene\pixelshift_nomotion.pp3 -t -c C:\Users\karsten\Pictures\Zerene

As you can see without spaces within the pathes and hence, without quotes.
It does work with -t16 as well, btw.

Many thanks for your support!


That’s correct. But bear in mind that sadly that Rawpedia page is outdated.

To take a look at the current «cli» options you will have to run: rawtherapee-cli -h (if RT is not present in the system path, then you will have to launch it from the folder where RT was installed).

It «does work» by coincidence: most probably that option will be ignored by RT, and all you will have is a fallback to defaults, which in your case are what you need: default is 16bit tiffs.

The correct options (to get the same result as with the defaults) are: -b16 -t

Last time I checked, the cli help reads as this:

-b<8|16|16f|32> Specify bit depth per channel.

8 = 8-bit integer. Applies to JPEG, PNG and TIFF. Default for JPEG and PNG.
16 = 16-bit integer. Applies to TIFF and PNG. Default for TIFF.
16f = 16-bit float. Applies to TIFF.
32 = 32-bit float. Applies to TIFF.

-t[z] Specify output to be TIFF.

Uncompressed by default, or deflate compression with ‘z’.

Hope it helps