RawTherapee & Mac OS Catalina

Hi everyone,

I’ve just installed for the first time RawTherapee on my Mac (running on Catalina 10.15.1).

I can go through all the folders looking for the raw files but it does not display any picture when I select the folders which contains raw pics.

Is there anything I missed when installing it?

Thanks.

Rafik

@rafiksr
It is a bug. Apple went a little ape on locking down folder access in Catalina. As a work around you can start Rawtherapee through the terminal. Using the open command.

open /Applications/Rawtherapee.app

Should work.
As far as I know they are working on a fix. This issue hit just about every open source program. Slowly they are all getting fixes.

Hi,
I also got Raw Therapee on Catalina 10.15.1. and I can’t access to my desktop. There’s folders on it an they don’t appear. One of them contains my raw files.
I tried to open it using the terminal and nothing changes…

Can you help me ?
Thank you

@Guillaume_Haas You need to give the terminal permissions. If you use the terminal to navigate to the directory you are having a issue with using cd command i.e. cd Desktop from your home directory MacOS will ask for permission. Allow the access then RT should also get access if you start it from the terminal.

Yes it is a pain and apple is dumb for doing this.

hum, thanks for answering me , but I don’t find where I have to go to give the permissions ?

If you open the terminal and navigate to the directory MacOS should handle that on its own. Alternative option might be to open settings got to security & privacy on the left select full disk access unlock settings with the padlock in lower left corner. Then use the + icon to add terminal to the list.

Thanks for the answer.

However, I dont know how to navigate through folders and execute a program (RawTherapee in this case) using commands in the terminal.

Anyone knows how?

When you open the terminal you are by default in your users home folder. To navigate the main commands you need are cd and ls. Cd changes directory ls lists directorys in location.

So when you open the terminal if you type ls then hit enter you will see a list of folders. Say you images are in Pictures. You would type cd Pictures then hit return now you are in the pictures folder.

To open RT you type
open /Applications/Rawtherapee.app and hit return.

Here is a link to help with terminal basics

https://www.google.com/amp/s/macpaw.com/amp/how-to/use-terminal-on-mac

Thanks Bill.

I did that and after trying to access Downloads (where my pics are) through Terminal, MacOS asks for permission which I give.

However, after launching RT, still no display of the pics.:pensive:

Just updated to Catalina 10.15.1 (from 10.13). Read the note about using RawTherapee 5.6 instead of 5.7. From the terminal:
cd /Applications
open RawTherapee.app

On the console Crash Reports new report appears, in that report is:

Termination Reason: DYLD, [0x3] Wrong version

Application Specific Information:
dyld: launch, loading dependent libraries
DYLD_LIBRARY_PATH=/Applications/RawTherapee.app/Contents/Frameworks

Dyld Error Message:
Library not loaded: /usr/lib/libexpat.1.dylib
Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
Reason: Incompatible library version: ImageIO requires version 7.0.0 or later, but libexpat.1.dylib provides version 1.0.0

How do I get the correct version of this library?

from the image RawTherapee_OSX_10.9_64_5.6

Solved. copied the librarary from an OS X 13.n backup