rawtherapee quits after startup

I updated rawtherapee with the script from rawpedia and it ran without error but when you start the program it opens for about 2 seconds and then closes. So I then compiled it with the debug flag and see that is give this error:

zsh: segmentation fault (core dumped) ~/programs/rawtherapee/rawtherapee.

I tried the suggestions in the crashs on startup article but they did not help. I’m using the current version of manjaro linux on a thinkpad and have been running rawtherapee for several years without any problems. Are core dumps caused by my computer rf the program code?

I had this effect also. It happened, when the last folder I worked on was on a disk which was not mounted at program start. If I mounted the drive before I started RT, it worked. Meanwhile I use the appimage which contains CR3 recognition - without this problem.

You’re right. The lfatpack version works okay and now I see that when it opens the file management is filled in with a directory structure. Whereas when I start the compiled version the file manager area is blank. When you say the appimage are you referring to the flatpack?

No, not really. appimage and flatpack are different techniques for the same intention.
Before telling pure nonsense, I’ll post a link: https://linuxconfig.org/snapd-vs-flatpak-vs-appimage-cons-and-pros-review.

A core dump contains a snapshot of the program state. They can be automatically generated by the operating system when a program crashes. In your case, the core dump was created when RawTherapee crashed because of a segmentation fault. A segmentation fault is typically caused by a bug either in the program or in one of the dependencies (libraries).

This kind of crash is usually easy to debug. Refer to this section of RawPedia for instructions on how to gather the required information. (It’s also possible to load the core dump into gdb if you’re having trouble reproducing the crash.)

f.y.i. I just compiled rawtherapee again (also on manjaro) - no crash at startup. After a short smoke test, it works like a charm. (And much faster…)

Kurt which version did check out with: dev or 5.9 staable? I’m trying to get the dev version working. I just re-did the whole process and I’m getting the same results: no directories or files in the file manager window and then it crashs.

I followed Linux - RawPedia
installed the dependencies, deleted the destination directories (\programs\code-rawtherapee and \programs\rawtherapee, just to be sure that’s really clean) and then started build-rawtherapee.
I used dev.
The compiler gave some warnings, but ended without errors.

I think the latest version of manjaro changed something and now the regular version of RawTherapee and ART will not run. The appimages do run. This is above my pay grade. How do we get the big-wigs programmers involved to figure out what changed and make the fixes to the code so that they run again?

This is part of the downside of running a bleeding edge, rolling distro.

If one of the devs uses arch or manjaro, they might be able to reproduce the problem.

You should see what has changed recently on your system and make a report with some debug info.

Dean: What you could do is to create a dump how Lawrence37 wrote. He provided a link to the “how to” - seems not to be complicated. I would do it myself, if I had an error.
These developers do a lot of work, without being paid. I think we cannot expect that they’ll test RT on all distros there are. What we can do to support them is to provide error descriptions with so much information as possible, eg the dump.

paperdigits: I won’t say you’re wrong. But I don’t think manjaro is bleeding edge. I’ve got more troubles with Windows… :nerd_face:

1 Like

Here “bleeding edge” means closer to the upstream latest released version of a package. I think Manjaro def qualifies. Here its likely that a dependency of an application updated and the application has not accounted for the changes in the dependency. This is common in bleeding edge distros.

Windows has its own set of issues that I don’t think are relevant to this kind of issue, as windows often requires apps to bundle their libraries.

Small-wig developer here. First, what do you mean by “the regular version”? Second, we need specific information to be able to diagnose the issue. RawPedia has the instructions on how to provide that information.

What I wanted to say:
I think it may be wrong to focus on Manjaro. I use Manjaro on a Intel-PC and an AMD-laptop.
The official 5.9 and the appimage (for testing CR3 support) provided by Lawrence37 work on both machines. And, as I wrote, I compiled the dev-version on my PC - and this works also. So Dean should (create the debugger logs and) write a useful bug report.

I’m sorry you feel this is an attack on something you like, but it isn’t. Its a detail in a specific problem.

I compiled the dev version with the debug flag and this is what it gave me: segmentatiion core dump. To quote myself:
“I tried the suggestions in the crashs on startup article but they did not help. I’m using the current version of manjaro linux on a thinkpad and have been running rawtherapee for several years without any problems. Are core dumps caused by my computer or the program code?”
I also notice that for the few moments that the programs is open before the crash that there is nothing in the browser file/directory windows.

Don’t worry - everything’s fine! Have a nice weekend!

I’m not a member of the RT team. So, I just point to Lawrence37 last post. If you follow these instructions, you’ll get a log from the debugger which you can create a bug at RT.
With this information a developer can try to debug; ‘Segmentation fault’ is far too general.
(And I just compiled it on my notebook - and it works.)

I bit the bullet and just re-installed linux and now ART and rawtherapee both install without a problem, just as they had been doing for the last several years. Thanks for the bandwidth everyone contributed.