"Read" node creating error

Compiled Natron on Arch Linux system using AUR (natron-compositor). It runs, but when trying to create a “read” node, it throws an error “Error while creating node fr.inria.built-in.Read: Could not find a decoder to read file format.” (for a sequence of png, mov, mp4, m4v). What can be done to solve the problem?

You are probably missing the plug-ins?

  • openfx-io
  • openfx-misc
  • openfx-arena
  • openfx-gmic

Oops, I thought the package natron-compositor would install all the necessary dependencies. Installed manually, really missed. But still, “read” node is not created with the same error.

Hi rodlie! Just downloaded Natron from the official website on my PC, running Windows 7, and I ran into the same issue here. It shows ‘Error while creating node fr.inria.built-in.Read: Could not find a decoder to read file format.’ whenever I try to drag an image file (JPG, PNG, etc.) onto the Node Graph.

You listed four plug-ins above, and I tried to check the bin folder to see if I have them, but I couldn’t find them. How would I be able to download these plug-ins? I also looked around on this site, but to no avail. (Maybe I am not looking at the right locations?) Thanks!

@dreamIIx : try to clear cache. Also run Natron from a terminal to see if you get any additional info (bad plugin?).

@Zelvio: Windows 7 is not supported anymore.

@rodlie, Thanks for the reply! After clearing the cache, still the problem continued. I run natron with __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia (maybe it’s useless by the way, haven’t figured it out yet) - it doesn’t give any errors in the terminal, only

Info: init.py script not loaded (this is not an error)
Info: initGui.py script not loaded (this is not an error)
libpng warning: iCCP: known incorrect sRGB profile

I rebuilt natron-compositor, but nothing has changed.
I compiled openfx-… from the AUR - the path to them is now /usr/OFX/Plugins/. I tried to add it to the search path for OpenFX plugins, but again nothing changed.
By the way, about two months ago I tried to build natron package on Arch Linux from AUR. But I caught a few errors when building some openfx-… Only the already built version from GitHub was installed, but it doesn’t suit me, for some reason it seems to me that I had memory leaks when working with video sequences (memory was not left to be allocated after assigned percent RAM). So I’m trying to build as said on GitHub via natron-compositor. Or is it wrong?

Is there a workaround? I saw a post that addresses the Windows 7 issue, and there was a solution to make it still work.

Natron 2.4.2 was the last version that supported Windows 7 (using a patched DLL).


The patch is for OpenImageIO, it replaces some code that required Windows 8+.

Natron 2.4.3 introduced OpenColorIO v2, and it requires Windows 8+ (v1 still works with Windows 7). It’s possible to patch it, but I will not “waste” time fixing it.

If there is enough demand I may consider a last unofficial Windows 7 release for Natron 2.4, but I would prefer not to :wink:

1 Like