really no chance for Gentoo and LUA scripts?

#1

Hey you all,

I hope my titel does not make you “ooohhhhhhhhh” :slight_smile:

I read and tried to implement those:

  1. https://forums.gentoo.org/viewtopic-p-8101168.html?sid=9f86d9130310e4bb30bec872e66c7a5c
  2. https://bugs.gentoo.org/618104
  • I have LUA 5.2.4 (and now also lua-5.3.5) finally unmasked and successfully installed (and emerge @preserved-rebuild)
  • eselect lua list shows correct 5.2.4 as active (tried now also 5.3.5)
  • generated a local darktable .ebuild with Lua on (attached zip)
  • luarc in place (attached zip)

Finally I can neither make dt 2.6.2 (with lua-5.3.5 it does not compile even) nor git-master handle lua after all.
“darktable -d lua” brings no errors but finally there is no scrip visible…

eix darktable clearly shows the USE of lua

Installierte Versionen: 2.6.2[1](18:11:10 23.03.2019)(cups gphoto2 jpeg2k kwallet lua nls opencl openexr openmp webp -colord -doc -flickr -geolocation -gnome-keyring -graphicsmagick -pax_kernel CPU_FLAGS_X86=“sse3” L10N=“de -ca -es -fi -fr -hu -ja -nb -nl -pl -pt-BR -ru -sl”)
[1] “localrepo” /usr/local/portage

Really no chance?

dt-ebuild_and-luarc.zip (2,3 KB)

Thanks in advance.
Cheers
Axel

(Bill Ferguson) #2

Try setting DONT_USE_INTERNAL_LUA to OFF in the CMakeLists.txt file in the toplevel darktable directory, then building and installing again.

That should let you use the internal lua interpreter

Hope this helps,

Bill

#3

Dear Bill,

I did so for git-master and it still the same behaviour, no error messages but also no evidence for LUA being active (e.g. hugin, which I am heading at)

Cheers
Axel

(Bill Ferguson) #4

Is your luarc file $HOME/.config/darktable/luarc? If it is, then add

local dt = require “darktable”
dt.print_log(“lua is working”)

then start darktable from a terminal with the -d lua argument.

If that works, then you can get rid of those 2 lines and put in

require “contrib/hugin”

#5

I do have a dt.print in my $HOME/.config/darktable/luarc and it does nothing (by that time lua 5.2 and 5.3, see below)…

There is another phenomenon: After I switched from gentoo’s standard lua 5.1 to 5.2 (and later 5.3), I got lot of machine freeze with MCE-errors, looking like hardware error. Beforehand my machine was working like a charm.

So currently I am back on lua-5.1 and rebuild dependencies (I know, from here lua is off :frowning: ) and observing whether or not my machine works stable again…

I am afraid, I have to give up here… :cry:

(Nick) #6

I tried it successfully some time ago by masking :0 Lua and installing slotted 5.3 instead. However that makes me to create new ebuilds in my local overlay for every new release of dt. At some point I decided that I don’t need lua that much… Lua situation in Gentoo is really a disaster…

#7

That is exactly my situation too. Not only get Lua 5.3 running but need to tweak the ebuild :frowning:

But I consider some of the available scripts @ multimedia4linux.whatever as useful…

(Nick) #8

Funtoo allows user-defined patches for ebuilds via foobashrc package while Gentoo doesn’t. You might try to install this package from funtoo overlay and use it…

#9

Other than bending my DIstro, I’d prefer dt could just accept lua 5.1 However, this has been refused on GitHub :-/

(Nick) #10

Yeah, it’s a step backwards, devs have a lot things to spend their time on instead. Lua on Gentoo generally has a complicated destiny for some unknown reason…