Registration doesn't find stars

Hello,
I’ve usual flat, dark, bias and light frames. I do the correct procedure as described here: https://discuss.pixls.us/uploads/short-url/y6K1nDx3zvKcGmZbyqvk7POzmLH.pdf (I actually coded that procedure in a siril script to use the command line).

Then, when it is time to register the lights, as my they are exposed for only 20s (it is m31, then I need different exposures to avoid blowing out the core), Siril is unable to register because it doesn’t find literally ANY star to do registration. This is not true of course, but I guess it has some threshold that makes it un-sensitive to 20-seconds stars (f6, ISO1600, 300mm focal lenght).
With the GUI I can select very small square in order to tell Siril to use that square to analyse stars, and strangely(?) it works (I draw the square just around a very bright star).

Now, one of the added value of Siril is the command line scripts. I really would like to solve this issue without any interaction with GUI. Is there any trick I could use ?

thanks in advance!

Alvise

Change star detection. You can access it through registration tab and the gear icon.

Unfortunately, no way: I’ve also tried to work on pre-converted tiff files with a higher level of luminosity (increased in CaptureOne before converting NEF->tif), but still nothing. Global star deep sky doesn’t work. Playing with threshold, roundness and other parameters for muc time didn’t help. This is a bit weird because a previous version of Siril (prior to the 0.99.4) was able to process this data.

Share a pic.

Yep, please download it from here: https://drive.switch.ch/index.php/s/5mr1U4vX7dU7nTm

Looks like your data are already stretched.
I need raw data.

And I can find stars on your image.

Ok, here the NEF: https://drive.switch.ch/index.php/s/TepzrUBpEXxG0yl
Below the piece of log of siril ran from command line:

Reading sequence file `cal_light20s.seq’.
cfitsio was compiled with multi-thread support, parallel read of images will be possible
Read from FITS header: pix size 0x0, binning 1x1, focal 0
bitpix for the sequence is set as -32
log: Registration: processing using method: Global Star Alignment (deep-sky)
progress: 0.00%
Read from FITS header: pix size 0x0, binning 1x1, focal 0
log: Reference Image:
log: Findstar: processing…
log: Found 0 stars in reference, channel #0
log: There are not enough stars in reference image to perform alignment
log: Preparing sequence processing failed.
log: Registration aborted.
log: Finalizing sequence processing failed.
Writing sequence file cal_light20s.seq

And attached the siril script. If you find any error you are welcome to fix it :wink:

siril-20s.txt (847 Bytes)

As you don’t make dark optimization, don’t preprocess your dark files with master-biases.
Because no problem with your images.

Does it relate to my problem of not finding stars ? or it is just a hint ? I would be surprised…
(just in case I tried to avoid the preprocess of darks, but still the same problem of 0 stars found…)

I tried with the GUI, same result. The only way to register the lights is (in the GUI) to do a manual selection of a single star and use it for alignment.

Please. Share a preprocessed image.

But there is an error in your workflow as you don’t subtract master bias from lights

So, combining the two errors that you found, this should be the correct script:

requires 0.99.6
set32bits
setmem 0.5
setcpu 4

BIAS

cd bias
convertraw bias -debayer -out=…/Siril -fitseq
cd …/Siril
stack bias median -nonorm -out=master-bias
cd …/

DARK

cd dark20s
convertraw dark20s -debayer -out=…/Siril -fitseq
cd …/Siril
stack cal_dark20s median -nonorm -out=master-dark20s
cd …/

FLAT

cd flat
convertraw flat -debayer -out=…/Siril -fitseq
cd …/Siril
preprocess flat -bias=master-bias -cfa -prefix=cal_ -fitseq
stack cal_flat median -norm=mul -out=master-flat
cd …/

LIGHT

cd light20s
convertraw light20s -debayer -out=…/Siril -fitseq
cd …/Siril
preprocess light20s -dark=master-dark20s -flat=master-flat -bias=master-bias -cfa -prefix=cal_ -fitseq
register cal_light20s -prefix=reg_
stack reg_cal_light20s rej 3 4 -norm=addscale -output_norm -out=m31
close
cd …
load Siril/m31.fit
savetif m31

Do you confirm ?

No. If you don’t remove biases from dark, don’t remove biases from lights

take a look here: https://gitlab.com/free-astro/siril/-/blob/master/scripts/OSC_Preprocessing.ssf

Thank you for that script.
I replaced all the “convertraw” with “convert” (and removed “-debayer”).
As shown in that OSC… script, I’ve used -debayer only as option of “preprocess” of the lights (and removed bias from this preprocess, as you pointed out).
Now I can successfully register the lights !

But the problem now, is that normalization fails. I will try to investigate myself, and in case I will open another topic, to avoid too much mess in this one.

Finally, IMHO documentation of commands (https://free-astro.org/index.php/Siril:Commands) would need to be improved a bit (made more clear, with more examples and use cases).

I think the page is heavy enough, use cases and examples can be found on the scripts page.

1 Like

Why don’t you use official scripts?
Also, you have Sirilic a software able to build your own scripts.

Ah, I didn’t know about Sirilic, I will definitely give it a try. Thank you!