removing "removed files"

(Peter) #1

I deleted JPEG from folder but DT still remembers them. So whatever I do (open “recently used collections”, switch from one collection to another and back, exit DT and run again or try to import again folder) I always have missing file icon
How can I can rid off them and see only currently available RAW’s?


If you are using Linux or some other Unix you can use

(Peter) #3

sorry, forgot to include:
2.4.1, Win10 pro
I also tried to cheat DT changing first character from capital but it didn’t help, DT isn’t case sensitive. So I added “1” at the end of folder name and made “import folder” again.


Ok, then the script won’t be of any help.

What did you mean, try to import the folder again? Are the image files still there on the disk and darktable can’t load them? Or did you move them away and darktable just has the stale entries in its database?

If you moved whole folders around you can set the collect module to “folder” mode and right click an entry in the list that is stricken through, then select “search filmroll …” and point dt to the new place. If you moved individual files to new places that won’t work and you have to select skulls manually and remove them from dt (hit del key).

(Peter) #5

Some time ago I imported folder with JPG+RAW. As I’m running short with disc space I removed jpegs and left only RAW for development. Darktable remembers there was a JPG - shows skulls and “image information” of non-existing anymore jpegs. I thought that if I chose “Import - folder” dartable would reload files (RAW only) that are currently on drive and will forget about JPEG’s. But it doesn’t. So darktable keeps somewhere information in its database. Removing them with del won’t be a problem if there were 10-20 photos, but my film roll had them over 900. So renaming folder and importing again only RAW is much easier than hitting 450 times del to remove skulls :slight_smile: This is consequences not check boxing “ignore JPEG files” at first import.

BTW feature request in two options:

  1. possibility to set by default “ignore JPEG”.
  2. if darktable finds two files with same file name (with JPEG and RAW extensions), give a choice box:
    Import JPEG only
    Import RAW only
    Import RAW+JPEG if corresponding RAW not present.
    Second would be best as I generally shot JPEG+RAW (so import only RAW), sometimes only RAW (no problem with import options) but also happens I have only JPEG. If I check “ignore” I have film roll with RAW only, next I have to go to “import image” and search for JPEG without corresponding RAW to make complete roll film.

(Mica) #6

There is already an option to ignore jpegs in the film roll, see


Those settings should already be remembered. So if you select that once you will have it pre-selected the next time you open the import dialog. I would have to check if importing from command line or via drag&drop honours that, too.

That is already available as a Lua script. Well, actually two scripts:

(Peter) #8

I’ll have to give LUA a chance :slight_smile:
Took a short look over on above script and maybe it would be possible to change in darktable from " ignore JPEG" to “prefer RAW over JPEG”, that is what I was trying to say in my post, here it is done in few words.

  • prefer raw over jpeg: this one is a bit more elaborate, it ignores JPEGs when there
    is also another file with the same basename, otherwise it
    allows JPEGs, too.