Resolution and pixel right side edge pixel stretch bug in Rawtherapee with Sony A7 IV's ARW files

Resolution and pixel right side edge pixel stretch bug in Rawtherapee with Sony A7 IV’s ARW files.
My Flickr. you can clearly see this issue with the pictures I’ve uploaded: Johannes Nilsen | Flickr

Irfan view shows the picture correctly, but Rawtherapee does not.
But an strange thing I noticed is Rawtherapee shows more than the Rawfile, for example I took a pic of a street with building on the right side, but a brick out of the frame shows in Rawtherapee, but not elsewhere.

I might update this, add more info later.

If I shot in compressed raw resolution was 7028x4688 but in Rawtherapee its stuck at 7032x4680

I now shoot Uncompressed raw so pics are 7008x4672 but Rawtherapee shows it as differently anyway. for some reason latest pics I took are 7028x4688.
Rawtherapee always shows 7032x4680 and with stretched right side pixels, not all pxiels are stretched, but most.
For some reason windows 11 thinks camera shot pictures in both 7028x4688 and 7008x4672. Irfan view show it’s 7008x4672. Rawtherapee only shows it as 7032x4680 no matter what.
i use Firmware V1.11 I’ve not tested 2.0 yet. do anyone know if it solves this issue.

1 Like


I see no raw_crop for your camera. Add that and see what will happen.

darktable crops 8 pixels from right side

1 Like

I’ve tried Sony Imaging endge Edit, it worked, then I tried Lightroom, it worked.
Rawtherapee needs an update. great software otherwise. So looks like I will be using Lightroom. It’s correct resolution, no artefacts.

That’s why I told you to add raw_crop.

Open camconst.json, find your ilce-7M4 and add
“raw_crop”: [ 0, 0, -36, 0 ],

Take a look at raw_crop for other Sony models.

1 Like

I’ve jsut tried it, it did not work.

It did not work. what did I do wrong? I tried both appdata local folder and programs folder
pixel and resolution issue is still there

Is there missing a comma?


… you used different quotation marks, may be thats a reason.

1 Like

Morrn, da!

@apostel338 is right; but the missing comma
is there, it is just mis-placed to the end of the raw_crop line.

So, remove the comma from the end of the raw_crop line, and add a comma after the ] at the line above where apostel indicated.

@marter Good catch! I missed that :-((((

Claes fra Lund, Sverige


I’ve done that, nothing happens.

Got an ARW and must say, it doesn’t work for me either. :person_shrugging: :man_shrugging: :woman_shrugging:

Now dinner time down here…
Click on my Avatar and send
as a personal message
your camconst.json and one of your RAW
files so I can see what happens with my own fingers…

What operating system are you on?

Mvh Claes fra Lund, Sverige

Missing comma and different quotation marks.
I don’t have any computer until next month and can’t try myself.

Windows 11, Rawtherapee 5.9

Hej, Johannes!

I have a hunch: did you use a word processor,
like Microsoft Word, or something similar, to
change that camconst.json file?

As stated above, please click my Avatar and send
me your camconst.json as a PM.

Have fun!
Claes i Lund, Sverige

Notepad. No idea how to send you a PM, there’s no way as far as I can see, maybe cus I am a new user to the forum.
I now use Lightroom.
But I also see Darktable has issues with the Sony raws, it squeezes the sides, but does not stretch pixels. Can’t do any colour adjustments, nothing works. But in Rawtherapee everything works, but resolution is wrong, and right side gets stretched pixel effect.

If you click on my C-dragon,
is there a yellow rectangel popping
up that says Message?

I will send you a PM, then you can simply reply :slight_smile:

that’s what I did, no such yellow rectangle appears for me.

Users should not have to mess with files to make the software work. so this should be updated. I don’t hate the software, but it needs to be updated. I’ve used it for years, but first time with Sony raw files.

Users should not have to mess with files to make the software work.

If users want to use new equipment
before its features are implemented,
why not?

1 Like