Resynthesizer/Heal selection in Gimp 2.10.10

After years of not having the Resynthesizer plugins since I had them a long time ago (Gimp 2.6?) and the stopped working at some point, I finally dug into the problem again a couple of weeks ago on Gimp 2.10.8. I got it working, the Heal Selection plugin was shining in the Filters>Enhance menu and it worked flawlessly. I think it is a lot better that the Inpaint tool in G’mic.

So yesterday Gimp was updated to 2.10.10. I was happy about that for some other reasons, but when I looked for Heal Selection it was gone!!! I checked my file manager, all the plugins are still present in the correct folder. Checked Gimp Preferences>Folders, and the plugin folder is still correct. So what has happened? Is something changed in 2.10.10 that breaks plugins that worked in 2.10.8? I haven’t seen anything about that in the release notes. And for such a minor update it should not either. Does anyone know?

And by the way, I’m on Linux Mint 19.1 with Gimp from Otto Kesselgulasch’s PPA: http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu bionic main

I have not tried that particular combination but I recall from the past that sometimes Python goes missing from those builds.

First thing is check that Gimp Filters -> Python-fu -> Console exists.

No python - no heal selection

Thanks for a quick reply. There is no Filters>Python-fu. Only Script-fu. I’m pretty sure I had Python-fu in 2.10.8. So how does this happen? Doesn’t the one who makes these builds care what he is doing? Is there any chance of getting it corrected?

There is a reason it is called gimp-edge. That is the way it works these days, I suspect a pre-cursor to a move away from Python 2.7

Again I do not have that particular mix (still contemplating an upgrade from (k)buntu 16.04 to 18.04)

You can try:

sudo apt install gimp-python*

might work although might conflict with that particular PPA

Eh, nothing too edgy about the latest stable release, is it? Anyway, there is nothing called gimp-python or anything like it to install.

That had me doubting my sanity for a while. I have a (k)buntu 18.04 - bionic - same as LM 19.1 and have a gimp-python So what is happening?

No good using the gimp (cutting) edge PPA gimp-python is not there.

However not there in ppa:otto-kesselgulasch/gimp at the moment. Used to be there, not there because there is no ‘bionic’ section for Gimp 2.10 showing.

I know there are dependency issues when compiling Gimp 2.10 on ‘bionic’. These seem to be resolved. Compiled just 2 (or 3) hours ago. This a screenshot of the PPA used for the preperations. https://i.imgur.com/amlF8qW.jpg

My advice, Dump gimp-edge. Wait a day until the ppa:otto-kesselgulasch/gimp updates. Add that PPA and install Gimp 2.10.10

I did it manually from the packages to give it a try. In Mint 19 Looks like this, with resynthesizer/heal-selection in action. https://i.imgur.com/XeAah1V.jpg

1 Like

I never said I used gimp-edge. :smile:

This is the one I use, as I clearly say in my first post.:wink:

So maybe if I wait a few days the problem will resolve itself, is that what you are saying?

My misunderstanding, confusing 2.10.10 with the development versions. Was there a 2.10.10 there earlier?

So maybe if I wait a few days the problem will resolve itself, is that what you are saying?

Basically, yes. You should see it in

https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp

At time of writing there is a 17.10 then it jumps to 18.10

Keep an eye open for 18.04 appearing then it should be in updates (using synaptic?)

Yes, it came rolling in via the normal updates a few days ago. Weird that it is missing now. I’ll just wait and see for now, then. Thank you for your time :grinning:

Just to tidy up, Gimp 2.10.10 for 'buntu 18.04/Mint19 (bionic based) is back in ppa:otto-kesselgulasch/gimp

The gimp-python package is there.

A quick check in a VM and it works ok.

Yes, it came in as an update today. After I installed gimp-python it worked as a charm again:grinning:

Thank you for your help.

What about Gimp for Windows ? Heal selection is missing there too…