RPD can't identify SD card as device in /media/ mounts

RPD assumes that my external drives are mounted at /media/{username}/

DEBUG: Probing for valid mounts
DEBUG: Media dir is /media/emoryy
DEBUG: To be recognized, partitions must be mounted under /media/emoryy

Well, they’re not. They are simply in /media/

This is because I have udisks2 configured as such that UDISKS_FILESYSTEM_SHARED is set to 1

http://storaged.org/doc/udisks2-api/latest/udisks.8.html

(Since I am the only user of my computer, I didn’t see the point in user specific media mount directories.)

To deal with your unique configuration see https://damonlynch.net/rapid/documentation/#scanonlyexternal

Thank you, that actually helped! After turning the option off the SD card appeared as a device immediately.

But I find this option quite unintuitive, as the name and description of that option doesn’t seem to be closely related to my problem. That’s the reason that I simply skimmed over it both in the options panel and in the documentation too, and didn’t try it. I just simply thought: yes, it’s checked, then what’s the problem.
I’m surely not understanding what is actually happening here, and why this helped. My SD card is still an external drive, of course, and it isn’t listed in the fstab either as the description in the documentation would imply.

It is named like that because when I wrote the program I did not anticipate that somebody would change the standard location all Linux distributions that I know about use to mount external devices. I wrote that option to account for users who manually mount network shares or other partitions in a random mount point on their system.

If systemd provides an option to mount external devices in /media and not /media/user then I may need to revisit that decision. If you know of a command that can be run to determine in one step or two steps where systemd mounts external devices that would be extremely helpful. It must be a command that abstracts away from configuration file details, because details like that are likely to change in future.

1 Like

I see. Thank you for explaining it.

I don’t know an exact command for just determining the actual media directory, but I tried lsblk like this:

lsblk -o NAME,RM,HOTPLUG,LABEL,MOUNTPOINT

The two related columns are RM and HOTPLUG. I first tried RM, “removable device” as explained by the help of the command, but this flag was only on for the SD card, while I have two USB external HDDs connected too. The HOTPLUG flag is turned on for these as well (description is “removable or hotplug device (usb, pcmcia, …)”. The MOUNTPOINT column gives the exact mount path of the drive, of course.