RT 5.10 ignores all input

opensuse tumbleweed 20240321
linux 6.8.1-1-default x86_64
AMD Radeon™ RX 580 2048SP
gnome desktop 46.0 wayland
RawTherapee, version 5.10

RT starts, shows its main page. And is inert henceforth. No clicks, drags, tabs, returns, verbal abuse make any difference to its complete lack of interest in input. It responds nicely to the kill signal from another terminal.

I note that ART suffers the same level of inert.

RT worked normally a couple of weeks ago, although it was probably v5.9 at the time. And most other system components were earlier versions.

Any ideas where to look for the problem?

look for a dialogue which might accidently be in the background.

I tried starting RT from a command line. There was nothing. ctrl-c did end the program.

Where else might a dialog be?

when RT is started press your super(windows) key.

in the window list you will see the RT/ART window and an about dialog in the background.

why that about dialog is in the background is a question for the devs.

Ah! There it is. And when closed, RT functions normally.
Thank you!

@agriggio @Lawrence37

can you maybe look into why the dialog is not in the foreground?

I have no idea how to do that.
It could be a timing problem: the main screen opens then changes in some way pushing the dialog into the background. Or some other reason.
Or that two threads are running and the dialog thread loses.
Or …

Do you have some “prevent focus stealing” option set in your desktop environment?
That might explain it, and if so, it’s something that should be addressed at that level, and not inside (A)RT (needless to say, the dialog shows on top normally, at least I’ve never experienced what the op describes).