RT 5.4 Performance optimizations?


(Ingo Weyrich) #21

Especially in METM (using multiple tabs with one editor per tab) the rt gui can get really slow on Windows


(Ingo Weyrich) #22

I hope you don’t think the same about my profile image :slight_smile:


(Marcos) #23

How do I get deletin’ these stuff, my friend?


(Marcos) #24

Hahaha they do say beauty is in the eye of the beholder!


(Marcos) #25

Trying the solutions first before screencasting, as my internet speed is 512k upstream, so it’ll take forever and a half before anything’s up.

Will do if nothing fixes it, however.

EDIT: Forum’s not allowing me to post any new posts now because I’m a newb. So you’ll have to wait a day for my lovely replies.

But, I can say this:

5.4 is using 95% of my CPU now when opening a picture. It’s impossible to use, actually. Very odd.

EDIT 2: Don’t know if you can still read me, Houston, but 5.0 R1 GTK2 is BLAZING fast. I did delete the lensfun stuff before I could get it to work, though, so I’m going to try to run 5.4 now and see if it’s made a difference there as well.

EDIT 3: Got 5.0 R1 GTK2 and 5.4 running. 5.0 R1 GTK2 is significantly faster, but it’s a 32-bit build. I will attempt to build manually for my system using GTK2 64bit setup.


(Ingo Weyrich) #26

First locate your lensfun directory. There are a lot of camera and lens files. Delete the ones, which are not relevant to your processing:


At next start of RT they won’t appear in the lensfun comboboxes, which should speed up the gui.


#27

Hello,
some time ago I opened a topic about compiling RT under windows because I also had problem with RT speed.
It took about 30 seconds for it to open, and it was very laggy when switching tabs. All operations were realy slow.
I tried every solution I could find, but nothing worked. Compiling did speed the programm up, but only for few seconds.
Recently I discovered that my BIOS was in legacy mode, not in UEFI mode. When I managed to switch the system to Uefi mode, all my problems dissapeared, and RT now works smoothly and fast.
Maybe that is not the same thing that bothers OP, but if someone else have similar proplem with Windows, maybe it could be helpful.


(Roel) #28

I find this very hard to believe. Maybe I am wrong, but UEFI or legacy mode only concerns booting your system. It should have no effect on the speed of your OS itself, let alone a particular piece of software you run.


#29

That’s what I thought also. But as soon as I switched to UEFI, RT started working 3 times faster. Now it opens in 4 seconds. And not only RT, one other programm I’m using is also few times faster now.
Maybe the problem was that I could not choose between EEFI and legacy, I first had to follow this procedure to enable UEFI.


#30

I have a pre-UEFI system so I won’t be able to do anything in that area. Might be the same for @idillicah since our processor gens might be the same (almost 1 year apart).


(Morgan Hardwood) #31

@Thanatomanic



#32

RT 5.4 runs much faster. Still sluggish but no more 12s wait times.


(Luis) #33

I sadly stopped using RT after the release of the GTK3 versions. RT was a monster, very very slow on my system (a Dell Precision 490 2,6Ghz 4GB Ram, Quad-Core Intel Xeon ) Now I am using RT again, the 5.4 release is working much better (congratulations!), but still slower than the GTK2 versions…
My OS is PCLinuxOS.
Please keep working improving the performance of RT.
Regards.


#34

Reporting that for me 5.4 on Windows 10 also is a huge drop in performance when editing photos. Thus GUI issues reported above seem likely.

It’s quite annoying, for example when clicking a handle and sliding it to the right, it can take 2 seconds before the slider starts moving and the effect in the photo becomes visible.

Working on 8-core CPU, 16GB RAM, NVMe SSD.


#35

As noticed above, could you indicate if your BIOS is a legacy BIOS or UEFI BIOS?


#36

It is UEFI.


(Vike) #37

I have noticed the same. Rawtherapee starts slowly and the image processing is sticky.

Specs

Windows 10 64-bit
CPU: Amd FX-8320 8-CORE 3.5GHz AM3+ 125W 8MB
RAM: G.Skill Ripjaws Gaming - DDR3 2133 MHz - 2 x 4GB
Power: Seasonic M12II620
Motherboard: Asus M5A97 EVO R2.0 SocketAM3 (Its UEFI and secure boot is on+ UEFI boot)
Sapphire DUAL-X R9 280 3GB GDDR5 OC PCI-E 3.0
Ssd: Crucial MX300 275 gt


(Vadim Ippolitov) #38

Ingo, thanks a lot for your instructions. I was experiencing serious lags in RT 5.4 on a 64-bit Windows 10 running on Core i7-4700MQ + 12 GB RAM + Kingston SSD (with UEFI BIOS, if that matters). In particular when switching back to RT window from some other application, the interface hanged for about 5 seconds every time, very irritating. But now I have moved all the lens definition *.xml files to a separate “unused” folder, except slr-canon.xml, which is the only one I ever need. After I restarted RT, the lag severity changed from “ugh, not again!” to “did it even lag?”

I think this is a serious bug, and should be fixed somehow. I was actually going to abandon RT because of this, but thankfully, you saved my butt :slight_smile:


(Morgan Hardwood) #39

@vadipp did this lag happen when switching back to RT even if you were not in the “Transform” tab?

Can anyone else confirm?


(Vadim Ippolitov) #40

@Morgan_Hardwood yes, the lag happened even if I was in the File browser tab! I could move the lens definitions back to reproduce the issue, and collect some logs for the devs, if someone kindly tells me how to do that…