RT 5.7 MacOS build ready to test


Thanks for testing!


Everyone: Please reply and state which version of macOS you tested on. Testing should including opening a raw file and successfully saving to JPEG.

Hi all, Perfecto!!! It works on MACPro early 2008 running OS 10.13.6.

What I tested and did not find any issues:

In file browser open a folder either with few (20) raw NEF files (D810), or with more than 2000 raw files.

Then edited some pictures and saved to JPG and also to TIFF. Also open, after dev, directly on external editor for further editing.

I used already saved processing profiles and saved and used a new profile, which I previously reported that was an issue with the previous 5.7 version, no problems with the new version.

Once again tank you all for the great work.

1 Like

Cool @zurdo thanks for your report!

I installed and opened the 5.7 version on MacOS 10.14.6

I only tried to load a NEF file and do some edits with exposure and dynamic range compression, so far so good…

I will try to do some more complex edits and save the result in the next days.

1 Like

I installed on MacOS 10.14.6. Can’t open it. First it “quits unexpectedly”. If I Retry, it says I don’t have permissions. If I go to Security and Privacy in System Preferences, and allow it to open, it opens Terminal and displays this:

/Volumes/RawTherapee_5.7/RawTherapee.app/Contents/MacOS/bin/rawtherapee-bin ; exit;

(rawtherapee-bin:89855): GLib-GObject-WARNING **: 10:47:17.501: invalid cast from 'GtkMenuBar' to 'GtkWindow'

(rawtherapee-bin:89855): Gtk-CRITICAL **: 10:47:17.501: gtk_window_add_accel_group: assertion 'GTK_IS_WINDOW (window)' failed

(rawtherapee-bin:89855): Gtk-WARNING **: 10:47:23.445: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.

This may indicate that pixbuf loaders or the mime database could not be found.

(rawtherapee-bin:89855): Gtk-WARNING **: 10:47:24.841: Could not find the icon 'list-remove-symbolic-ltr'. The 'hicolor' theme

was not found either, perhaps you need to install it.

You can get a copy from:



Gtk:ERROR:../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)

Abort trap: 6


Saving session...

...copying shared history...

...saving history...truncating history files...


[Process completed]

Interesting. I would have to investigate further as none of my machines produce this error.

@HIRAM when making new test-builds, consider adding a hash or something in a place which will appear in these dumps, to make it explicitly clear that user are in fact testing your latest build.


Not so much luck at my end…

Running on Mac OSX 10.15 (Catalina) on my Mac Mini (2018) it gets to the following error message:
" The last time you opened RawTherapee-bin, it unexpectedly quit while reopening windows. Do you want to try to reopen its windows again? "
Clicking on “don’t re-open” causes a crash, as does clicking on “re-open”.

This is still better than RT 5.6 which does not even get that far - just one bounce of the icon.

Running on Mac OSX 10.14.6 (Mohave) on my MacBook I get the same message with this build. However, unlike before, I click on “don’t reopen” and it opens fine. It also opens a raw file (ARQ) and I can save it to jpeg.


Hey guys,

Running Mac OS 10.15 (Catalina) on my 2019 21.5’’ 4K iMac. Using a CR2 Raw File from my T7i.

Few notes to make. I had to run the application from the Terminal in order to access the computers file system. This seems to be a big issue with almost all open source software using GTK on Catalina not sure why apple feels it necessary to Lock everything down so hard. At least I can work around this with a terminal launch.

I did have a one crash well more like the process just terminated with no actual errors just a process completed message in the terminal. I believe it happened when I was messing around with Dynamic Range Compression and Highlight Compression. Only saw it happen once not sure what happened there.

Jpeg exporting worked flawlessly. No crashes also had no startup crashes.

I did do a test to see how the application handled without actually changing my Mac into (low res mode) low res mode looks terrible. Still some performance issues where the ui feels sluggish. The processing seems to operate reasonably but the sliders can be a bit janky and occasionally the preview lags for a split second on update. I am sure this should sort itself out once you guys get some GPU support in.

Also it seems lens correction profiles are missing. Even happens on my personal builds not sure what is up there but I rarely use them on my type of landscape shots just usually aberration corrections.

All and all seems to be working well despite the obvious Catalina paranoid lock everything down and the minor stuff mentioned above.

If there is a way on OSX to figure out what caused the crash I would be more then happy to mess around and try to get some info there was just nothing it just kinda closed like I hit the quit button with a small amount of edit loss.

Goodmorning everyone and what a great day! These are the data of my test with the new version downloaded at the link above.

Model name: MacBook Pro
Model identifier: MacBookPro 5.5
Processor name: Intel Core 2 Duo
Processor speed: 2.26 GHz
System version: OS X 10.11.6
Kernel version: Darwin 15.6.0
RAM: 8 GB DDR3 at 1067 MHz
Graphics Card: NVIDIA GeForce 9400M 256 MB

Files processed and saved both in Tiff 16bit and in JPEG:
RAF from Fuji S5 Pro
RAF from Fuji X-PRO 1
NEF from Nikon D300
NEF from Nikon D700

For the moment I have not encountered any other problems.
A big and sincere thanks from my heart to all those who work for RawTherapee.

1 Like

… I wanted to confirm that with my Mac configuration this version works fine. I worked all this day without any problem. Very very thanks :heart_eyes::heart_eyes::heart_eyes:


No problems doing the recommended basics on a recent MBP running 10.14.6. Various sliders, presets, and output all look good and seem snappy. Big thanks!

1 Like

I cannot run the test build on my machine running Catalina 10.15

Getting the following in the crash log…
Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x3] Wrong version

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /usr/lib/libexpat.1.dylib
Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
Reason: Incompatible library version: ImageIO requires version 7.0.0 or later, but libexpat.1.dylib provides version 1.0.0

MacBookPro 2016 Quad-Core Intel Core i7, 2.7 GHz, 16 GB RAM, Intel HD Graphics 530 1536 MB

Ok, that’s a pair of Apple libraries. Wonder why the version mismatch is going on.

The Lens correction profiles are indeed missing, no other issues.

Version: 5.7
Branch: 5.7
Commit: f335efe6a
Commit date: 2019-09-10
Compiler: clang
Processor: generic x86
System: Apple
Bit depth: 64 bits
Gtkmm: V3.24.1
Lensfun: V0.3.95.0
Build type: release
Build flags: -std=c++11 -std=c++11 -mtune=generic -Werror=unused-label -mmacosx-version-min=10.9 -flto -Wall -Wuninitialized -Wcast-qual -Wno-deprecated-declarations -Wno-unused-result -Xpreprocessor -fopenmp /opt/local/lib/libomp.dylib -I/opt/local/include -Werror=unknown-pragmas -O3 -DNDEBUG -ftree-vectorize
Link flags: -mtune=generic -headerpad_max_install_names -flto
OpenMP support: ON
MMAP support: ON

I will have a look tonight at it.

I downloaded RT from the default download page and had a problem with it and so then I found this thread and the link, but appears to be the exact same version (10.9_64_5.7). I guess that it was tested and then made the default version?
The problem I have is that RT runs and allows me to open a photo, but as soon as I click the floppy disc icon to save the image RT immediately crashes.

I am still running macOS High Sierra version 10.13.6 on a MacBook Pro (17-inch, Late 2011) and this laptop cannot be updated as the GPU is too old for Metal.

I got the following crash report on screen with information on 75 threads, 74 of which I have snipped out of the below:-

Process:               rawtherapee-bin [420]
Path:                  /Applications/RawTherapee.app/Contents/MacOS/bin/rawtherapee-bin
Identifier:            com.rawtherapee.rawtherapee
Version:               5.7.0 (5.7.0)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           rawtherapee-bin [420]
User ID:               501

Date/Time:             2020-01-01 15:02:39.401 +0100
OS Version:            Mac OS X 10.13.6 (17G10021)
Report Version:        12
Anonymous UUID:        8BEA0EA3-DB37-C9D7-DBD7-F7F0B4D244D1

Time Awake Since Boot: 150 seconds

System Integrity Protection: disabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x4] Symbol missing

Dyld Error Message:
  Symbol not found: _objc_alloc_init
  Referenced from: /Applications/RawTherapee.app/Contents/Frameworks/libgio-2.0.0.dylib (which was built for Mac OS X 10.15)
  Expected in: /usr/lib/libobjc.A.dylib

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   dyld                          	0x000000010dc34256 __abort_with_payload + 10
1   dyld                          	0x000000010dc33bc8 abort_with_payload_wrapper_internal + 89
2   dyld                          	0x000000010dc33bf5 abort_with_payload + 9
3   dyld                          	0x000000010dc07482 dyld::halt(char const*) + 354
4   dyld                          	0x000000010dc075a9 dyld::fastBindLazySymbol(ImageLoader**, unsigned long) + 170
5   libdyld.dylib                 	0x00007fff75405292 dyld_stub_binder + 282
6   ???                           	0x0000000106af92b0 0 + 4407136944
7   libgobject-2.0.0.dylib        	0x0000000106d62b09 g_type_create_instance + 889
8   libgobject-2.0.0.dylib        	0x0000000106d4fdc6 g_object_new_internal + 54
9   libgobject-2.0.0.dylib        	0x0000000106d4f60c g_object_new + 252
10  libgio-2.0.0.dylib            	0x00000001069f5f7b try_implementation + 123
11  libgio-2.0.0.dylib            	0x00000001069f5db6 _g_io_module_get_default + 486
12  libgio-2.0.0.dylib            	0x0000000106a64a5e g_settings_backend_get_default + 30
13  libgio-2.0.0.dylib            	0x0000000106a6c32a g_settings_constructed + 218
14  libgobject-2.0.0.dylib        	0x0000000106d4fec8 g_object_new_internal + 312
15  libgobject-2.0.0.dylib        	0x0000000106d4fb3b g_object_new_valist + 731
16  libgobject-2.0.0.dylib        	0x0000000106d4f5aa g_object_new + 154
17  libgtk-3.0.dylib              	0x0000000107838275 _gtk_file_chooser_get_settings_for_widget + 101
18  libgtk-3.0.dylib              	0x0000000107842101 settings_load + 33
19  libgtk-3.0.dylib              	0x000000010783a4dd gtk_file_chooser_widget_set_property + 685
20  libgobject-2.0.0.dylib        	0x0000000106d507c5 object_set_property + 325
21  libgobject-2.0.0.dylib        	0x0000000106d4ff04 g_object_new_internal + 372
22  libgobject-2.0.0.dylib        	0x0000000106d502dd g_object_newv + 253
23  libglibmm-2.4.1.dylib         	0x0000000106c5d2a3 Glib::Object::Object(Glib::ConstructParams const&) + 547
24  libgtkmm-3.0.1.dylib          	0x000000010712b5f5 Gtk::Object::Object(Glib::ConstructParams const&) + 69
25  libgtkmm-3.0.1.dylib          	0x00000001070cbc15 Gtk::Widget::Widget(Glib::ConstructParams const&) + 69
26  libgtkmm-3.0.1.dylib          	0x0000000106f9f2fd Gtk::Container::Container(Glib::ConstructParams const&) + 61
27  libgtkmm-3.0.1.dylib          	0x0000000106f648f5 Gtk::Box::Box(Glib::ConstructParams const&) + 69
28  libgtkmm-3.0.1.dylib          	0x0000000106fe721d Gtk::VBox::VBox(Glib::ConstructParams const&) + 61
29  libgtkmm-3.0.1.dylib          	0x0000000106fc7a55 Gtk::FileChooserWidget::FileChooserWidget(Gtk::FileChooserAction) + 165
30  rawtherapee-bin               	0x0000000105da4330 SaveAsDialog::SaveAsDialog(Glib::ustring const&, Gtk::Window*) + 384
31  rawtherapee-bin               	0x0000000105bf8300 EditorPanel::saveAsPressed() + 272
32  libgiomm-2.4.1.dylib          	0x000000010672f5a4 sigc::slot0<void>::operator()() const + 84
33  libglibmm-2.4.1.dylib         	0x0000000106c65f31 Glib::SignalProxyNormal::slot0_void_callback(_GObject*, void*) + 81
34  libgobject-2.0.0.dylib        	0x0000000106d4962d g_closure_invoke + 189
35  libgobject-2.0.0.dylib        	0x0000000106d5fafc signal_emit_unlocked_R + 2124
36  libgobject-2.0.0.dylib        	0x0000000106d60831 g_signal_emit_valist + 2353
37  libgobject-2.0.0.dylib        	0x0000000106d60e92 g_signal_emit + 130
38  libgtk-3.0.dylib              	0x000000010776cfe8 multipress_pressed_cb + 136
39  libffi.7.dylib                	0x0000000109311d65 ffi_call_unix64 + 85
40  libffi.7.dylib                	0x000000010931115a ffi_call_int + 794
41  libgobject-2.0.0.dylib        	0x0000000106d4ab46 g_cclosure_marshal_generic_va + 1302
42  libgobject-2.0.0.dylib        	0x0000000106d49816 _g_closure_invoke_va + 198
43  libgobject-2.0.0.dylib        	0x0000000106d6043f g_signal_emit_valist + 1343
44  libgobject-2.0.0.dylib        	0x0000000106d60e92 g_signal_emit + 130
45  libgtk-3.0.dylib              	0x000000010786bdb8 gtk_gesture_multi_press_begin + 408
46  libgobject-2.0.0.dylib        	0x0000000106d4cea4 g_cclosure_marshal_VOID__BOXEDv + 180
47  libgobject-2.0.0.dylib        	0x0000000106d49816 _g_closure_invoke_va + 198
48  libgobject-2.0.0.dylib        	0x0000000106d6043f g_signal_emit_valist + 1343
49  libgobject-2.0.0.dylib        	0x0000000106d60e92 g_signal_emit + 130
50  libgtk-3.0.dylib              	0x000000010786a1da _gtk_gesture_set_recognized + 122
51  libgtk-3.0.dylib              	0x0000000107867c21 _gtk_gesture_check_recognized + 161
52  libgtk-3.0.dylib              	0x0000000107869320 gtk_gesture_handle_event + 304
53  libgtk-3.0.dylib              	0x000000010786e23d gtk_gesture_single_handle_event + 877
54  libgtk-3.0.dylib              	0x000000010782482c gtk_event_controller_handle_event + 156
55  libgtk-3.0.dylib              	0x0000000107a63644 _gtk_widget_run_controllers + 244
56  libgtk-3.0.dylib              	0x0000000107a6fc02 gtk_widget_real_button_event + 34
57  libgtkmm-3.0.1.dylib          	0x00000001070c8b31 Gtk::Widget_Class::button_press_event_callback(_GtkWidget*, _GdkEventButton*) + 321
58  libgtk-3.0.dylib              	0x0000000107ab6165 _gtk_marshal_BOOLEAN__BOXEDv + 421
59  libgobject-2.0.0.dylib        	0x0000000106d49816 _g_closure_invoke_va + 198
60  libgobject-2.0.0.dylib        	0x0000000106d6043f g_signal_emit_valist + 1343
61  libgobject-2.0.0.dylib        	0x0000000106d60e92 g_signal_emit + 130
62  libgtk-3.0.dylib              	0x0000000107a63160 gtk_widget_event_internal + 800
63  libgtk-3.0.dylib              	0x0000000107a62e34 gtk_widget_event + 116
64  libgtk-3.0.dylib              	0x00000001078cb342 propagate_event_up + 98
65  libgtk-3.0.dylib              	0x00000001078ca40a propagate_event + 410
66  libgtk-3.0.dylib              	0x00000001078c9c62 gtk_propagate_event + 50
67  libgtk-3.0.dylib              	0x00000001078c9569 gtk_main_do_event + 1817
68  libgdk-3.0.dylib              	0x0000000107e24e05 _gdk_event_emit + 69
69  libgdk-3.0.dylib              	0x0000000107e579bf gdk_event_dispatch + 79
70  libglib-2.0.0.dylib           	0x0000000106de8e86 g_main_context_dispatch + 310
71  libglib-2.0.0.dylib           	0x0000000106de9212 g_main_context_iterate + 514
72  libglib-2.0.0.dylib           	0x0000000106de952f g_main_loop_run + 191
73  libgtk-3.0.dylib              	0x00000001078c8c9c gtk_main + 108
74  libgtkmm-3.0.1.dylib          	0x0000000107009991 Gtk::Main::run_impl() + 17
75  libgtkmm-3.0.1.dylib          	0x0000000107009814 Gtk::Main::run(Gtk::Window&) + 164
76  rawtherapee-bin               	0x0000000105ccd230 main + 4336
77  libdyld.dylib                 	0x00007fff75405015 start + 1

Thread 1:
0   libsystem_kernel.dylib        	0x00007fff75555a16 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff7571e589 _pthread_cond_wait + 732
2   libomp.dylib                  	0x000000010667cafd __kmp_suspend_64 + 269
3   libomp.dylib                  	0x0000000106665784 kmp_flag_64::wait(kmp_info*, int, void*) + 1652
4   libomp.dylib                  	0x0000000106661960 __kmp_hyper_barrier_release(barrier_type, kmp_info*, int, int, int, void*) + 144
5   libomp.dylib                  	0x0000000106664d1f __kmp_fork_barrier(int, int) + 495
6   libomp.dylib                  	0x0000000106645e4c __kmp_launch_thread + 508
7   libomp.dylib                  	0x000000010667b71a __kmp_launch_worker(void*) + 330
8   libsystem_pthread.dylib       	0x00007fff7571d661 _pthread_body + 340
9   libsystem_pthread.dylib       	0x00007fff7571d50d _pthread_start + 377
10  libsystem_pthread.dylib       	0x00007fff7571cbf9 thread_start + 13

Funny thing is, I do have the file that it mentions in the error message:-

philippscanuks-MacBook-Pro:~ philip$ ls -al /usr/lib/libobjc*
-rwxr-xr-x  1 root  wheel  16748736  4 Jul  2018 /usr/lib/libobjc.A.dylib
lrwxr-xr-x  1 root  wheel        15 16 Oct 01:19 /usr/lib/libobjc.dylib -> libobjc.A.dylib

maybe nm -gu output is useful

philippscanuks-MacBook-Pro:~ philip$ nm -gu /usr/lib/libobjc.A.dylib