RT 5.8 not working after upgrade from MacOS Monterey to Ventura 13.0.1

Hi. Been using RawTherapee 5.8 for nearly 3 years now. Recently purchased a Mac Mini - which originally came with MacOS Monterey. I installed RT 5.8 and it worked perfectly. Just a couple of weeks a go, the OS updated to Ventura. Since then, some of the tools and functions in RT have stopped working. For example I cannot click on any of the bundled profiles (but I can view them) and I cannot select any of the lens profiles, even though I can see them. I have tried uninstalling/re-installing but to no avail. Any tips/suggestions?
Apologies of the question has been asked before. Thank you in advance.

You should try the latest Dev vereion, though I’m not sure that works either.

Did you make a full Time Machine backup of your system on Monterey before you installed the barely Beta-tested Ventura - even Apple recommend you do that.

You should always seek advice before jumping to a new Mac OS.

If you did, then install a fresh Monterey OS to an external SSD, then use Migration Assistant to move your apps etc from the TM backup BEFORE you installed Ventura.
Once done, restart the machine holding down OPTION until you see the boot picker then select the external SSD as your boot drive - that should work with a bit of luck.

But seriously, never jump Mac OS unless you HAVE to - Apple are just using you as an advanced beta-tester!!

I didn’t know any of this to be honest! I switched to Mac after 23 years of using PC’s. I bought the Mac Mini M1 in September of this year - which came with Monterey pre-installed. I started using it straight out of the box on day one! So when the prompt came up about 3 weeks a go to perform the update to Ventura, I thought nothing of it and just did as instructed on-screen. Wasn’t aware that Ventura was still at beta stage. Anyway, as the computer is still fairly new and there’s hardly any data on it, I could roll back to Monterey using the Time Machine backup. Will know better for future though! Thanks for the heads-up.

No problem Abid, just remember, Apple are not your friend so update nothing until you have checked first!

1 Like

Hey guys. This is a gtk bug. Every GTK apps are facing this issue: widgets not reacting to mouse hover/click on macOS Ventura (#5305) · Issues · GNOME / gtk · GitLab

Waiting for a fix.

1 Like