RT disappears somewhere if I switch from it to another program

windows 10 22h2
rt - I don’t know, where I can view app version.

i7-12700K/rtx4070 12GB/32GB ram (I didn’t make this font big).

Does anyone know where the program collapses if I switch from it to other programs - Google Chrome, Firefox etc?
There is an icon on the taskbar as if I closed it. I have to open it again, but there is no history of my actions, like in Lightroom, if I open it again. History is disappearing somewhere.
It’s not in the system tray either.

I understand and respect OpenSource developers. But the question, based on the practical state of affairs - should the program be closed if I want to switch to the window of another program? So that the processing settings are saved and not to do everything again.

This sounds like a windows problem and not a RT problem. I had numerous programs disappearing off screen after one of windows famous updates. It took me a fair while and a bit of google searching to find out how to return the lost programs to my screen.

Check in your task manager that the program is open and running in the background. In my case I have multiple screens and this contributed to windows problems. BTW, the programs disappearing on me were not RT but other programs.


It’s clear. I’ll try to reinstall the system. Updates cannot be removed. “servicing stack” etc.

No, the program still disappears somewhere.
I have already reinstalled Windows and was not installing updates.
The program does not remain in the processes.
Do you need to compile the program yourself from source, like under Linux?

Where can I look for what I did with the photo?
When I opened the program again, it was as if I had not processed the photo. Maybe the program has some kind of auto-save history?

No problem for me…I am on Win11 but I never saw this in the past either…if I switch away there is an icon in the taskbar…


The edits are saved in the sidecar and your image should open with the edits but RT does not save the history for an edit so once you close RT or move to a new image its gone…

I honestly don’t understand what you’re talking about. You don’t have any problems, so what?

It is likely that unless you close the program and switch from one file to another, the program does not save the changes. Well I do not know. The chronology is as follows:
I work in my own program and don’t bother anyone.
I minimize the program, or switch to another application - any. Then I look, and the status of the rt application is on the taskbar, as if I had not opened it at all. It’s not running.
I open the program again and see that the file is as if I had not done anything with it.
Probably, before minimizing the program, if I need it, I need to switch to another raw file and back. Then changes are made to the pp3 file - this is a kind of insurance.

But automatically I can forget to do this. I’m not used to OpenSource software, it’s simple. I rarely use gpl software.
+I ask a question, and people answer you “it works for me.” And what? This is also a strange answer.
Maybe you mean that you have a standard for the quality of hardware and system configuration? Sorry.

You asked…I answered…your edits are saved in a sidecar file the pp3. There is just no history displayed the next time you open the image so it might look like there were no edits. If things were working your edits should have been saved in that sidecar file and retrieved and applied when you went back to RT and opened your image again… I stress should have as clearly it sounds like something is going wrong.

It seems for you that from what you said the second you switch away from RT it crashes and likely without saving the pp3 I would guess since you open the image and there is no sign of the edits…

I tried a couple of ways to leave RT and return to it, both by exiting and alt tab and simply selecting another running program including chrome from the taskbar and I did not have your experience so it would seem there is an issue with the install or something but I am just saying that I dont’ see that and I have not heard of this …that doesn’t mean that it doesn’t happen…

Trying out the debugging steps might provide the answer


You should figure out what is killing RT or why it is dying or crashing. Are you running antivirus? If so, can you turn it off?

Thank you for paying attention to me.
Yes, there is an antivirus out of the box from Microsoft.
I’ll turn it off and see the result. I know how it turns off.

So you think the application is crashing? Can you find the crashlog?

Btw, little good is done in chastising people who are trying to help you. If you don’t find their help useful, probably better to just ignore it.

You hint at this, but just to clarify - The pp3 is resaved EXTREMELY often (possibly every time you make an adjustment in history? I’d need to dig through that part of the source, but it’s definitely frequent), so it’s extremely unlikely that you’ll actually lose work, just the history of the work you did prior to that point.

The behavior described by OP is NOT normal. RT is crashing on their system, and not most other people’s, so without debugging information from them it’s not really possible to help them.

1 Like

No, I can’t. It is logical to assume that the program creates logs, if it has such a function, in the user space, and not in the system, since I do not run this program as an administrator - it is designed like many other programs. But I didn’t find its logs in my profile. Appdata contains only cache and configuration with profiles. At the userprofile \ the same thing. When it falls, it doesn’t even wave its hand, like other programs do, for example.
Most likely, it could show something if I launched it from a terminal shell, like under Linux, but I have Windows.
It fault again and at the most inopportune moment.

There is one very interesting moment :slight_smile: that I have been observing for many years. If you do not respond to all topics on your problem, then outside observers may consider the topic not relevant, even if they have an answer or an accompanying question. Yes - a normal person will still answer. I agree here. But, alas. Not everyone does this. This is the psychology of people, or something. + it is advisable to keep the topic afloat.

I have already checked both the memory (memtest86) and the power supply using s&m. The program can be used for 12 hours and it does not crash (when you switch from the program window to another window), but it can fall out of the blue - you just click on the title of its window, or minimize it by clicking on the program button in the taskbar and do this often - once an hour.

I reinstalled the system. I don’t install updates. The updates from about 10 months ago are only worth it. windows 21h2.
The hardware is new, I bought it about a year ago and left hackintosh, thinking that the new video card would be useful for graphics (cuda).
I already have an idea (well, honestly, I understand that this cannot be written) to work with photographs in Davinci Resolve, since processing them in Adobe is a real hell. I have never seen such a horror of processing as they did in Adobe and C1 even in Davinci. Although, I purchased a subscription from Adobe for a year. For photo retouching, well, firefly in ps. This functionality is sometimes needed. In stable diffusion I can’t do what I can do in firefly in photoshop.
I still have Photivo and it doesn’t crash. I don’t run it in parallel with rt. But photivo is very tricky and complex. + the font is very small for me.

Well then I guess we should start from the beginning:

  1. Where did you get the rawtherapee installer from?
  2. How did you install it? Where is the rawtherapee.exe
  3. How are you launching rawtherapee?
  1. https://rawtherapee.com/shared/builds/windows/RawTherapee_5.10_win64.zip
  2. a. from exe file, that I download from one 1. I’d extract zip file and run exe file. A standart process install. b. “C:\Program Files\RawTherapee\5.10\rawtherapee.exe”.
  3. I’m running that one from windows shortcut, that was created by installer, that staying in C:\ProgramData\Microsoft\Windows\Start Menu\Programs\RawTherapee. If I’m opening a shotcut settings window, that I watch, that one see to “C:\Program Files\RawTherapee\5.10\rawtherapee.exe”.

I am going to come up with another suggestion for you to try. Install darktable which is another FOSS photoediting software like RT. install | darktable

Then see if the same problem occurs with this software. If it doesn’t you then have the option to stick with DT as an editor or continue working out what is going wrong with RT. If DT also misbehaves this would probably also be informative.

Can you launch rt from cmd.exe and share any output here?

1 Like

No matter what I do in dt and no matter how I do it, the result is “Lara Croft”))). A very high quality picture that makes you sick. A very banal, mediocre, correct result, no matter how hard I tried to work there. That’s why I won’t go back to DT either by hand or by foot. This is my specialty.
But I understand you. I’ll work in Davinci for now, although it’s not convenient to crop pictures there. There you need to constantly set the size, like a film. The program is not designed for photographs, but it can be adapted just fine. But at least the photographs in it will be alive, and not “Lara Croft”.
RawTherapee does not suffer from this, unless you touch lab curves and some other miracle tools.
Well, or 3dlut creator. I bought it about 5 years ago.