RT is running slow on my new iMac

(Børge Rokseth) #21

Hi,

here is a video showing some general sluggishness.https://pixls-discuss.s3.dualstack.us-east-1.amazonaws.com/original/3X/e/c/ecfc842e8d7f203a67020eda916d70d4268fec85.mp4

(Ingo Weyrich) #22

where?

(Børge Rokseth) #23

Sorry, I now updated the post to actually include the video :slight_smile:

(Ingo Weyrich) #24

Please test again using RT 5.5 from here

(Børge Rokseth) #25

Same trouble it seems: https://pixls-discuss.s3.dualstack.us-east-1.amazonaws.com/original/3X/7/3/7366e8e2e49d9c8e286b1db87b7f309758a40012.mp4

(Ingo Weyrich) #26

Is this an iMac with 4K or 5K display?

(Børge Rokseth) #27

I’ve got the following specs:
Screen: Retina 4K, 21.5-inch
Processor: 3,6 GHz Intel Core i7
Memory: 16 GB 2400 MHz DDR4

(Ingo Weyrich) #28

An (I guess) 4 core/8 HT Intel is not the best solution for RT on a 4K display. Preview processing time in RT increases with number of pixels in preview.

Though it would be interesting to see how an RT mac build optimized for newer cpus performs. Maybe @HIRAM can make an I7 build to check or at least a build which supports FMA and AVX (that would also include SSE4 automatically).

In my tests a native windows build for my AMD FX8350 performes much better than a generic build which is restricted to SSE2 features.

#29

no problem except I’m overseas until March 21, and I unplugged my build machine, but I can definitely take a look when I get home. Looking at the screencast… what is acting sluggish? Is it being sluggish relative to another system’s performance?

(Ingo Weyrich) #30

No need to hurry. I also don’t see a really sluggish behaviour in the video.

(Morgan Hardwood) #31

4k in your case probably means 4096x2304 according to some Apple website. Based on your video, RawTherapee in your case is working with a 2440x1628 preview size, or almost 4 megapixels.
I have a 1920x1080 screen, my preview size is 1215x815 or 1 megapixel.
As @heckflosse already pointed out, the preview size is roughly proportional to the preview processing time. Your system has to crunch 4 times as many numbers as mine does.
You have an i7 3.6GHz CPU and 4 megapixels to process, while I have a 0.9GHz CPU and 1 megapixel, so comparing the two is not straightforward, but it seems the lag between an event and the preview updating in your video is more or less what would be expected.

Lightroom uses the GPU for some operations, and RT does not (yet).

Side-note: number-crunching aside, using KDE feels much faster on this slow CPU than it did on my previous i7 CPU, I’m guessing that’s to do with the newer instruction set extensions supported by this CPU and by the SSD disk.

2 Likes
(Ingo Weyrich) #32

I guess you also use a native build of RT

(Børge Rokseth) #33

Really? There is at least half a second of delay every time I press a button or pull on a slider. Perhaps it is really not so bad, or it may not transfer well to video. It may also perhaps be unreasonable to expect more responsive behavior, but it feels awkward and sluggish to work with.

(Børge Rokseth) #34

This sounds sensible to me. I don’t notice much difference, however, when I reduce the preview window (se video).https://pixls-discuss.s3.dualstack.us-east-1.amazonaws.com/original/3X/a/9/a90e15f774a7292b711e10a61b3a5c2fbf4582e9.mp4

(Morgan Hardwood) #35

It’s hard to tell what you’re seeing because your video is very jerky, maybe your system is incapable of recording a smooth video at 4k.

(Morgan Hardwood) #36

Try setting both AdjusterMinDelay and AdjusterMaxDelay to 0 (while RT is closed).

#37

Hi I have the same issue. Brand new iMac retina 5K, 27inch 2017, 4,2 GHz Intel Core i7, 40 GB 2400 MHz DDR4, Radeon Pro 575 4096 MB

Opening pictures takes about 1,5 seconds, scrolling through the folders is quite slow also. I could live with that but when I use the sliders there is a serious delay between the movement of the mouse and the actual slider. Up to a point that it’s very difficult to work and almost impossible to be precise. This is a real bummer because I really wanted to use RT. I haven’t found any solutions anywhere. Nothing worked for me.

I recently downloaded Capture1, the free trial, and that works much smoother. Is the problem due to the 5K 27 inch screen? Is there no way RT will work smooth on a 27 inch 5K iMac?
I have an SSD and was convinced this iMac would have no issues with any photography software. I had Lightroom on my previous iMac 21 inch and that worked very smooth, no delay whatsoever.
I’m quite disappointed having spent almost 3000€ on a computer that’s now slower then my old one…

1 Like
#38

Have you tried the dev branch build? Also which macos version?

(Bert Riffelmacher) #39

I dont know if it’s related, but I experience similar problems with darktable and other gtk software on Mac OS. I tried 10.13,10.14 my hackintosh and an original MacBook, and the Ui is always very slow and unresponsive.
Running dark table the same specs on my hackintosh under windows or Ubuntu 18.04 it is much faster. On Ubuntu it really flies.

(Morgan Hardwood) #40

To isolate the problem a bit:

  1. As @HIRAM wrote, use the latest development build when testing,
  2. Change your screen resolution to 1920x1080 and test. (i.e. do not just resize the RT window to 1920x1080 because then you’re still running at 4k or whatever)
  3. If you can reproduce the problem at a screen resolution of 1920x1080, record a 30fps video and upload it here.