Running rawtherapee-cli on mac osx high sierra

Hello :slight_smile:

I am totally new to rawtherapee and currently a tiny bit stuck… I would like to run some calls to rawtherapee in a python script via rawtherapee-cli but it seems like the rawtherapee-cli command cannot be found… when i try to link the full path to rawtherapee-cli via calling it as /Applications/RawTherapee.app/Contents/MacOS/rawtherapee-cli the command is found but sadly converting .tiff images to jpgs does not work…

I have used the installer from the rawtherapee website and I am using OSX High Sierra and python3.6

Thanks in advance!

Can you run the rawtherapee-cli command from the terminal? What is the result?

1 Like

Hi - thanks for answering so quickly! :slight_smile: When I run it i get:
-bash: rawtherapee-cli: command not found

if you do this in the terminal:

cd /Applications/RawTherapee.app/Contents/MacOS/

then

./rawtherapee-cli

does it work?

1 Like

Yes! It returns:
RawTherapee, version 5.5, command line.

Terminating without anything to do.

ok that is good.

If you try to convert a raw to a tiff using the ./rawtherapee-cli, what is the outcome?

1 Like

when trying
rawtherapee-cli -o /Users/sa/Desktop/test/foo.tif -s -t -Y -c /Users/sa/Desktop/test/download_RAW_instructions_v2/Conversion_script/devHome/ALASKA_RAWs/Canon-EOS100D-RebelSL1_instance1_0001.CR2

i get
-bash: rawtherapee-cli: command not found

If you’re in the folder /Applications/RawTherapee.app/Contents/MacOS/

then you need the ./ before the rawtherapee-cli command:

./rawtherapee-cli

The problem you’re having is that the rt-cli isn’t on your system path, so bash doesn’t know where to look for it. I’m not a macOS user, but I assume this tutorial is still good: https://www.architectryan.com/2012/10/02/add-to-the-path-on-mac-os-x-mountain-lion/

You need to add /Applications/RawTherapee.app/Contents/MacOS/ to the /etc/path file as detailed in the tutorial.

4 Likes

Thank you very much!
./rawtherapee-cli worked in the folder and I am currently adding the path to my /etc/path file :slight_smile:

3 Likes

Fantastic!