Safari 12.1.2 no longer opens this forum

Safari 12.1.2 (macOS 10.12.6) no longer opens this forum, until yesterday it worked. Now I have to use Chrome or Firefox.

What happens? Is there an error? The more info the better. Could be something like this flagged by Malwarebytes as having a trojan.

No, no malwares, neither Etrecheck nor DetectX find anomalies.
I just see a blank page when I select Discuss.

A little bit of an aside:

Safari 12.1.2 is nearly 3 years old (July 2019) and has a bunch of security issues that were fixed in later versions of Safari.

You may want to upgrade your version of macOS if you can. (If not, I understand how it is; I have an old mid-2009 MacBook Pro where that’s not possible. It’s still stuck on Mac OS X… and dual boots with Linux.)

If there’s no newer version of macOS for your hardware, you should seriously consider using another browser, as any browser that isn’t up-to-date has security issues. The older a browser is, the worse off it is.

While Safari is tied to macOS, the latest Firefox, Chrome, and most others are available for older versions of macOS.

(FWIW: The latest versions of WebKit work fine with this forum. I’m looking at it with GNOME Web 40.1, which is mainly equivalent with Safari 14.6, so this isn’t completely Safari-specific.)

If you’re only using Safari for sites that don’t matter much (like forums), then it’s probably not too bad (unless you used shared logins)… but if you’re using it for banking, online purchases, and the like, it should be a pretty big concern.


Thanks for the Safari tips but as you assumed it’s the most up-to-date version available for my old 2011 iMac.
I just wanted to understand what could have changed on the forum to stop me from opening it with that version of safari (until yesterday it had no problems).
In addition, even the automatic translation of Chrome no longer works for a few days on the forum, while it continues to work with other web pages.
Maybe the forum administrators are making some changes and would like to be informed if possible
Thank you.


From the discourse github page:

Discourse is built for the next 10 years of the Internet, so our requirements are high.

Discourse supports the latest, stable releases of all major browsers and platforms

You do not want to use such an outdated browser or OS. you are missing a lot of security fixes for both.

Ok, I changed my default browser.

I have a similar problem: my smartphone is an iPhone 5s. I know, it’s old, but it works, and I’m not buying a new one until this one dies.

OS version is 12.5.3. There will be no more updates for this hardware, or at least a version 12.6 is not expected. Ever.

I can’t access discuss (this forum), or to be more accurate, a page «loads», but it’s a completely blank page.

I have tried with Safari, Firefox (same Safari engine), Opera, Opera mini and Chrome. All the same: blank page.

Should I understand my smartphone+browser is no longer supported?

1 Like

on iOS all browsers use the same engine as Apple did not allow other engines to be shipped.


Indeed, Apple requires all vendors to use Webkit on iOS, which is unfortunate if people cannot access the current release version.

PS One thing that people can do is open a radar to let Apple know this issue. Do it or remain forever silent!

1 Like

To me, it’s even more unfortunate that less than 8 years from its announcement (not from start selling it), a smartphone it’s not only considered a piece of junk, but it’s forced to not work in a website…

Perhaps it’s the way things have to evolve…

Apple tends to be hyper-focused. It works hard on the one thing at the expense of others. When it returns to the old thing it is already woefully broken.

Sadly tech doesn’t seem to be made to last anymore. While iPhones have a decent hardware life span (when apple doesn’t hinder them on purpose) a 7 year old phone just isn’t viable today.

If you’re interested in longevity, perhaps check out the Fair Phone.

1 Like

Unfortunately, such phones are inaccessible to most people. An android phone with the long term support commitment of a custom OS is more realistic. (I have yet to attempt such an installation.)