Scripts - Exiftools returning no Data

HI All

New to PIXLS and new to Darktable (currently lightroom user - recently switched to Fuji and trying to avoid “worms”)

So i’m slowly finding my way around darktable. Most is simple but i’m trying to streamline my amateur workflow. I have followed instructions regarding setting styles and luts up to auto apply on import to Darktable. I have followed the guide here. Darktable for Fujifilm Cameras I am using windows 10

My issue is that on import the script doesnt run (script is started - all styles and LUTS are setup as they should be) I get 2 main errors first is related to exiftool (this is monitoring a log via git bash)

 [C]: in ?
310.453136 LUA "E:\Photography\Photography\Lightroom\Darktable\exiftool\exiftool.exe" -AutoDynamicRange -t "E:\Photography\Photography\Image Files\Fuji XT4\2022-07-02 - Fremantle\20220702-X-T4-DSCF0496.RAF"
310.464872 LUA ERROR [fujifilm_auto_settings] no output returned by exiftool
310.464906 LUA "E:\Photography\Photography\Lightroom\Darktable\exiftool\exiftool.exe" -DevelopmentDynamicRange -t "E:\Photography\Photography\Image Files\Fuji XT4\2022-07-02 - Fremantle\20220702-X-T4-DSCF0496.RAF"
310.476346 LUA ERROR [fujifilm_auto_settings] no output returned by exiftool
310.476446 LUA ERROR : ...a\Local\darktable/lua/contrib/fujifilm_auto_settings.lua:191: attempt to concatenate a nil value
stack traceback:
        [C]: in metamethod 'concat'
        ...a\Local\darktable/lua/contrib/fujifilm_auto_settings.lua:191: in function <...a\Local\darktable/lua/contrib/fujifilm_auto_settings.lua:169>
        [C]: in ?

The next is when using the -d startup from cmd, in the cmd window I get (twice per file import):-

The Filename, directory name, or volume label syntax is incorrect.

So I am assuming that exiftool cannot be found or ran by the script. Hence the null value return

The oddity is that if I use the command directly (from the bash error) “E:\Photography\Photography\Lightroom\Darktable\exiftool\exiftool.exe” -AutoDynamicRange -t "E:\Photography\Photography\Image Files\Fuji XT4\2022-07-02 - Fremantle\20220702-X-T4-DSCF0496.RAF in a cmd prompt it returns the value as it should.

Does anyone have any hints as to what may be the issue?

I have contacted the author of the script and he has been very helpful, but did all of his testing on Linux… therefore its probably an issue with me being on windows.

I am not code / developer terms savvy… so if you can imagine you are talking to a child that would help greatly :slight_smile:

Thanks in advance


I can’t really help in debugging the issues (having neither Windows nor a Fuji camera), but:

  • do you need those scripts for your way of working (i.e. if you always use the same aspect ratio, you can set up an auto-applied preset for the crop, with no need to look at the metadata)?
  • can you temporarily remove steps from your process until you get no more errors?
  • could you show us how you rename the files on import?

And in general, I try to avoid spaces and dashes in file and directory names, they are usually more trouble than they are worth (I find the required quoting annoying :wink: ). It’s a long shot, but if for any reason those quotes are stripped off between the LUA script and exiftool, you may have problems…
A test with a directory and files without spaces and dashes in the names could also help here.

Thanks for the reply.

Being a rank amateur and just using the camera for family photos and documenting our outings my workflow is unlikley to be optimal. Coming from Lightroom (13 years in total) i’m just looking for something better with Fuji. I’m also a business owner and father to a 5 year old so time is a rare commodity! I want to shoot raw to give me some processing freedom (as that is what I was doing with pentax since the beginning) but minimise the amount of processing I do for “snapshots” that I want to keep / Share with Family

I’m trying to get it so that when I import the files, that certain presets / Styles are applied to the raw files to get the standard fuji ‘provia’ look as an initial start. From here I can tweak… as it is I dont really want to manually do what Lightroom already does. The more I look into styles and presets the more I think I possibly dont need the script now, but I just cannot wrap my head around how the presets are applied. On import 12 preset are applied automatically and I cannot see where!

Re the import - I have already imported the files from the camera within lightroom (as I needed to get them processed) so the file names etc are already created in the simple folder structure I have and all I am doing is adding the files to the library.

With this script all it does is determine the brand of camera, cross references the colour profile used in camera and applies the appropriate ‘style’ to the raw on import. So there are no processes other than that. The DR200 / 400 styles are relating to the selectable dynamic range in camera and emulates that as is the crop matching what is done in camera (I think) I’m new to Fuji and Darktable…

I’ll try moving some images to a folder with no spaces and see if that makes a difference too… appreciate the thought on that. I just found it wierd that I get a result manually doing the commands - but via the script it falls over… so makes sense re stripping the quotes.


I don’t have dt on Windows, so I can’t test, but my guess is this is not a long shot at all. If the quotes are stripped off, then the blanks will cause only a part of the file name to be treated as a file name, and Exiftool will not find the file.

Do you mean this stuff in your history?

If so, that is the set of tools that are auto-applied when you open a photo. Check your darktable preferences:
processing → auto-apply pixel workflow defaults

and read here (or equivalent for your release):

This thread is essentially in reference to Help Me Build a Lua Script for Automatically Applying Fujifilm Film Simulations (and more). But for some reason, exiftool seems to not return results for @5teve on Windows.

Where did you install Windows from? I’ll have a look if I can’t reproduce the behavior on my Surface tablet, our last Windows device in the house.

Hi Bastian

Sorry I didnt see your reply… I’m just using windows home on a Xeon workstation (has some fairly high end disk in) be interested to see if the surface behaves the same…


Thanks Gord… that makes sense re the presets… and the file names etc. I’m starting to understand it a little more. It Filmic I really need to get my head around as it destroys the fuji raws on import with deep dark shadows… hence looking at this script.

This is my first foray away from lightroom so I’m just looking at options for Fuji.
1 Lightroom - and then use topaz to denoise / sharpen for specific images as LR NR isnt great
2, DXO raw converter and LR (DXO does a nice job of messy images)
3, DXO Photolab - Looks ok - does a good job of converting raws but hate the lack of live preview
4, Darktable - Looks to be incredibly powerful, with a corresponding learning curve. I’ll get there eventually but my time is limited for learning… (and im also a little lazy) - I just cannot quite get the colours there… yet.

Not being commercial and just using the software for “snap shot’s” I cannot justify C1 or similar. Lightroom I can deal with as I use PS for other stuff… and its cheap - but the fuji thing is not great and the workaround an inconvenience!


Hey Steve, you mentioned that you are using the DR200 and DR400 dynamic range settings, and then you mentioned that when you opened the raw files in darktable the shadows were crushed.

I think your problem may be that when you use DR400, the boost to the shadows done in camera for DR400 is only done to the JPEG. When you open the raw file in dt, you are getting a raw file that is two stops underexposed, without the shadow boost. Someone else brought up something similar a few months back, and I meant to take the time to put together a nice test/demo case, but time has been in short supply!

This article has some good details:

1 Like

HI Gord

Thanks for the link… I have DR switched off… the mention was that bastians script has the ability to recognise if its been used or not and apply a style to deal with it. Its something i’ve wanted to look into so appreciate the link. I’mgetting some good reading / watching put together now (I have 11 hours on a plane coming up) as I am with you on the time thing… it really is the most precious resourse at the moment!

The Filmic i can dial back on contrast to around 0.8 and it brings everything back… but i’m sure thats the simple way not the right way. I’ll try and post a comparison when I get a sec of what I mean regarding this… I also need to try bastians latest LUTS as I didnt realise he had a new set… and is still working on them I think…

Thanks for bearing with me… new to Darktable and to fuji… a lot to learn!


1 Like

How are you launching exiftool? Windows has different quoting requirements than Linux

Well, the contrast is the contrast in the mid-tones. If you have a large dynamic range in your image (i.e. a large difference between white and black reference points in filmic) a high contrast will have to compress the highlights and the shadows (the almost flat areas in the curve shown by filmic).

Lowering the global contrast gives the shadows and highlights more room, but the image ends up looking a bit dull/flat. That’s where local contrast comes in. You can use either the “local contrast” module or the “add local contrast” preset from “diffuse and sharpen”.

Or you can use the “tone equaliser” module, or “exposure” with masks, but that’s more complex in use. On the other hand, you have more control over where the changes are made, once you learn how to use those tools.

And we have to use such “tricks” to get the dynamic range to where we can reproduce it: modern cameras can have 12-15EV dynamic range, an LCD screen has about 10 EV and paper about 7 (or less).

You had mentioned that exiftool on your computer would only produce output in an admin prompt, but not as a user.

I just downloaded the Windows version of exiftool from, renamed the executable to “exiftool.exe”, and added its directory to the PATH environment variable. After that, I was able to execute “exiftool” in a non-admin CMD prompt without issue.

I then tried to set up Darktable, the styles, the LUTs, and the Lua script. Darktable went fine, of course. The styles and LUTs and script from my website apparently had broken links, sorry about that! (links are fixed now). Installing the styles and LUTs worked, too.

However, the Lua script installer in Darktable did not seem to work on Windows, and I couldn’t get my lua script to execute. Does anyone know what’s up with that?

Hi Bastian

I did mention it yes and I think that it was because I had the exiftools executing from my ‘downloads’ folder (even though it was in paths) once I had moved it to a non ‘user’ folder it seemed to execute from a non admin cmd… so probably my issue (or i’m going mad) as i mentioned in my email - exiftools executes fine - even using the path provided in the error log from DT works in the cmd prompt as a copy and patse … which makes it even more strange… hopefully someone can point you in the right direction… :slight_smile:

As for the broken links… I think i worked them out… but you did also link them from another post on here… so need to check them out if they are the same ones.

The script installer worked for me in windows (i think) i just ran the git fetch (but I think i found the commands on here) to get LUA installed. I then uninstalled everything and reinstalled DT and it then prompted me to download and install LUA… The first time It certainly wasnt straightforward nor documented well… for windows… After reinstall it was easy with the promt and doing it automatically. I got your script installed and running… it just doesnt do what its meant to because of the exiftool issue… which seems to be a quote thing… maybe… possibly :slight_smile:

Your help is appreciated :slight_smile:


This sort of tone equalizer works pretty well for DR200, and double all values for DR400:


It looks closest to the original with preserve detail = eigf.

Indeed I am still working on these LUTs. My current work-in-progress has been recompiled for filmic v6, and is meant to be applied after filmic (as opposed to e.g. Stuart Sowerby’s LUTs that are meant to replace filmic): (55.1 KB)

While I like my LUTs, and use them all the time, they are not perfect, and do not perfectly reconstruct the JPEG colors. I don’t yet know why. They sure get closer to the JPEG colors than without the LUTs though.

An up-to-date lua script can be found on Github:

1 Like

The lua scripts installer requires that you have git installed, and in your path. If you don’t it should have popped up an error message.

Windows requires an extra set of " "s when scripting commands. So you need to amend Line 129 from:
local command = exiftool_command .. " " .. flag .. " -t " .. RAF_filename
local command = '"' .. exiftool_command .. " " .. flag .. " -t " .. RAF_filename .. '"'


Thank you! This did the trick for me!