seqsplit_cfa error

I have installed the most recent version of siril 0.99.6.
The command seqsplit_cfa produces an error , which did not happen in the previous version 0.99.4.
I entered “seqsplit_cfa sub_” on the command line in the siril GUI. My sequence is named “sub_”

The messages reads :

log: Running command: seqsplit_cfa
1606657180: running command seqsplit_cfa
Reading sequence file `sub_.seq’.
Read from FITS header: pix size 3.92x3.92, binning 1x1, focal 0
log: Reading FITS: file sub_00000.fits, 1 layer(s), 6024x4024 pixels
bitpix for the sequence is set as 20
ERROR:…/src/core/processing.c:336:seq_prepare_hook: assertion failed: (args->has_output)
Bail out! ERROR:…/src/core/processing.c:336:seq_prepare_hook: assertion failed: (args->has_output)

It runs on a windows10 machine.
Am I doing something wrong here ?
Thank you for your help !
Best regards, Jan

I think I’ve seen an error in the code because this function is written to receive no argument while it definitely should. Maybe there are other errors.
You should use UI to do that for now.

thank you for the quick reply!
I want to use it in a script that I execute from a powershell using the pipe stream. I’ll revert to version 0.99.4 where it does work. Hopefully it can be fixed in the next release.
Thank you! Jan

Sure it will.

I’ve fixed it for the next version. Thanks for the report, that was indeed an error.
This function, CFA extraction, does not work on SER or FITS cube files, it’s a limitation we should mention somewhere or we could think about extending it to support them.

Thank you for solving this problem !
I noticed another strange thing: when I issue the command “crop [x y width height]” using the command line in the GUI, the result is different then if I do the crop from the drop-down menu when selecting the crop area with the mouse . I am using version 0.99.4 on windows. ( I read the command displayed in the ‘undo’ arrow on the top.) Cheers, Jan

Commands done with the command line cannot be undo.

Yes, I know. But when I reload the original image and do the command line crop, the result is different then when I did it using the mouse ?

It looks as if the command “crop [ x y width height]” ignores the value of ‘x’. The result is equivalent to crop [ 0 y width height].

I just did a test. It looks ok for me.

strange …I can’t get it to work correctly in my case …
It could be something with the exact syntax.
When I type : “crop ( 200, 700, 300, 300)”
then the console message is:
1607101188: running command crop
log: Crop: select a region or provide x, y, width, height
log: Command execution failed.

But when I type: “crop (200, 700, 300, 300)” (no leading space in front of x)
then the console message is:
1607101376: running command crop
log: Crop: processing…
log: Execution time: 0.00 ms.
In this case, the command worked and it produces a square image of 300px by 300px, but it has definitively (as I can see from the stars) ignored the x value of 200 and used 0 instead. The y value was correctly accepted.
Adding or removing spaces in other places can also make the command fail…

I want to use the command to crop L,R,G,B images identically.
I am using version 0.99.4 on windows10
Thanks, Jan

Remove parenthesis. They are not needed.

Yes now it works !
(I was misled by the inline help and the documentation Siril:Commands - FreeAstro. Should maybe updated ?)

Thanks a lot!

1 Like

Yes definitely and I will test for parameters too

Oh in fact [ and ] means optional.