Since 1.19: Thumbnails don't load after resize

As the title says.

See screencast. This seems new since 1.19 (official build).

I tried all combinations of the thumbnail settings in performance options, as well as the embedded jpg setting and clearing cache.

Pressing F5 fixes this for me.

Only a partial fix for me. Leaves some thumbnails refreshed and others still not visable.

Bug confirmed – sorry!
I’ll release a 1.19.1 asap

1 Like

Right. I chose to hit that button


which equals F5 to make it visible what I was doing.

Should be a bit better now. The whole handling of thumbnail updates would need a bit of refactoring, because I think there are still glitches here and there, but this is for another time…

1 Like

Looks good, thanks.

1.19.1: on Windows, if you switch back to the navigator view from the editor view, only the edited thumbnail is shown, the rest is empty, until you hit F5 and they are all refreshed.
Doesn’t matter if you use the cached thumbnails feature or not.

Oh, good catch. Also on Linux when I switch from Edit to Browser, mostly only the thumbnail of the photo you were editing is shown and a random amount of thumbnails that are “off-screen”, depending where your scroll position is.

That’s what you get when you release without proper testing.
Anyway, I just did what I should have done immediately: I reverted to the old behaviour. Hopefully it works as 1.18 now. Sorry for the mess.

I hardly dare to say it, but the resize thing is back.

Oh dear. I just killed 1.19 altogether, I’ve had enough. Just pretend it never happened. I will release a 1.20 eventually


Feel free to delete my thread and eliminate all evidence. :upside_down_face:


Here’s a new (windows) version to test:

This time, I will let it stay here for a couple of weeks at least, to see if anything else pops up. No installation needed, just unpack and run. In the meantime, I’ll restore the binaries for 1.18.1

For me it seems that 1.19.2 candidate is fine. Thank you for your effort.

It looks OK to me. Thanks!

Let’s see if I got it right this time… I just released a 1.19.3 version.


Looks quite good to me. Now I can only provoke non-loading thumbnails by switching their size really fast (faster than ART can update the view). But I would rather consider that a rare case of user misbehavior.