Siril hangs on local disk access

Hi all,

I recently setup an Allsky Camera on a Raspi. I activated Samba on it so I can download the data from my Windows 11 PC. I did NOT map a shared folder of the Raspi in the Windows File Explorer.

Now every time I load a file from my local disk into Siril, I can see the image right away but then it becomes completely unresponsive for a while. Same when I want to save a file. But as soon as I turn on the Raspi, it behaves normally again.

I use the Allsky only on imaging nights out in the fields. The rest of the time it’s supposed to be stored away. But it seems for now I’ve to turn it on everytime I wan’t to do some processing :confused:
Do you have any suggestions on how to get around this?

Thank you, kopi

Hello again,

today I uninstalled Siril and reinstalled it again.

Unfortunately it hang right away for about half a minute.

And it does this for every load and save action. This is very frustrating.
I also tried to delete everything Siril related in the AppData folders and the Windows Registry.
No luck, only when I power on the Raspi, there are no hangs.
Siril is the only application that behaves this way. All other apps on my PC aren’t bother whether the Raspi is reachable or not. No Windows Explorer, no Gimp, no nothing.

Another thing, as with all my apps, I’ve installed Siril not under C:\Program Files\ but under C:\apps. During all the updates, I never had to specify the installation directory again which was fine.
But now that I’ve uninstalled it, I wasn’t asked neither and now it just installs under C:\Program Files. How can I get it to install wherever I want it to be?

Thanks, kopi

GTK+ hangs on windows when there is an unconnected drive, local or remote. If you have unused drives, please remove them and check again.


We have removed specifying the path to install from the installer as it was creating all sorts of problems. If you want to install someplace else, please refer to this section of the docs:



thank you cissou8 for the clarification.

Thank you for your reply.
May I ask what you mean by ‘unused drives’?
I have no mapped network drives, no pinned drives and executing the net use command on the shell also just shows There are no entries in the list.

Is there a way to find out why QTK+ even tries to connect something that isn’t there? How does it even know that it should look for it?
I enabled the developer mode in Win11 to might some more debug infos but the log in the console didn’t change.

Initializing FFTW multithreading support...
log: Welcome to siril v1.2.0
log: Supported file types: BMP images, PIC images (IRIS), PGM and PPM binary images, RAW images, FITS-CFA images, Films, SER sequences, TIFF images, JPG images, PNG images, HEIF images.
log: Setting CWD (Current Working Directory) to 'C:\Users\kopi\Pictures'
log: Parallel processing enabled: using 20 logical processors.
Successfully loaded 'C:\Program Files\Siril\share\siril\siril.css'
Successfully loaded 'C:\Program Files\Siril\share\siril\'
log: Searching scripts in: "C:\Program Files\Siril\scripts"...
log: Loading script: Mono_Preprocessing
log: Loading script: OSC_Extract_Ha
log: Loading script: OSC_Extract_HaOIII
log: Loading script: OSC_Preprocessing
log: Loading script: OSC_Preprocessing_WithDrizzle
log: Loading script: RGB_Composition
log: Loading registration method: 1-2-3 Stars Registration (deep-sky)
log: Loading registration method: Global Star Alignment (deep-sky)
log: Loading registration method: Two-Pass Global Star Alignment (deep-sky)
log: Loading registration method: Image Pattern Alignment (planetary - full disk)
log: Loading registration method: KOMBAT (planetary surfaces or full disk)
log: Loading registration method: Comet/Asteroid Registration
log: Loading registration method: Apply Existing Registration
log: Default FITS extension is set to .fit
Last available version: 1.2.0

After dropping in a file

Purging previously saved reference frame data.
TIFFReadDirectory: Warning, Unknown field with tag 50000 (0xc350) encountered.
TIFFReadDirectory: Warning, Unknown field with tag 50008 (0xc358) encountered.
TIFFReadDirectory: Warning, Unknown field with tag 50011 (0xc35b) encountered.
log: Reading TIFF: 32-bit file stacked32.tif, 3 layer(s), 4144x2822 pixels

And after I click the save icon, select a local path and click save the Saving TIFF dialog appears while this single line is appended to the console

The URI points to a local file.

and the dialog immediately freezes for another about thirty seconds.
After clicking Save again, the file gets instantly saved and a new line is logged to the console

log: Saving TIFF: 16-bit file C:\Users\kopi\Pictures\stacked32.tif, 3 layer(s), 4144x2822 pixels

Thank you, kopi

Had the same issue which drove me nuts. Reinstalls, searching Registry, Roaming directories, etc. - no link to old network drives could be found anywhere.

Here is what worked for me:

Delete Windows Explorer Favorites/Shortcuts to old non-existing network drives.

Apparently Siril always checks validity of the shortcuts on startup/setting work directory/loading/saving which has a long timeout…

Another tip:
If you know you had used an old network drive with Siril which is no longer available, you can fake the access to your local PC instead, thus immediately circumventing the network timeout:

Put a line at the end (in my case the missing network drive was called wdmycloud): wdmycloud

However remember this if you ever want to use a network drive with this name again…