Siril Opening Canon Raw Files Mirrored Along Y Axis

Technical Details:

  • MacOS 10.14.6
  • iMac Pro (10 core, 128GB RAM)
  • Siril version 1.2.0
  • Canon 7D Mark II
  • Siril Log (txt file) (19.9 KB)

Problem Description:

I have started to have a problem where some raw files open vertically mirrored (the top and bottom of the image are flipped). This did not happen with these same files in the last Siril version I was using.

On top of this, the images flip again during the preprocessing step and come away incorrectly debayered. There is no usable color information after the preprocessing step. This seems to imply that the data is being read out in the wrong order and messing up the RGGB pattern.

Is this a known bug? I can’t be the only one using Siril with 7DII raw files. I’m probably going to just switch back to a version that works for now, but if anyone has any ideas I’ll be willing to try things out as well as provide more information on the issue.

Hello and welcome.

Please could you read this document FITS — Siril 1.2.0 documentation to tell us if it is what your are experiencing.

These are not FITS images. They are canon raw files. The two are not really related.

As far as I know, Siril actually uses a third party library (DCRAW?) to handle opening CR2 images, so maybe the issue lies there…

No. LibRAW.

Ah, sorry. Maybe I was thinking of DSS or IRIS.

As far as I can see in the preferences menus, all of the raw processing settings are for the decoding of FITS images, with the possible exception of the debayering/demosaicing algorithm. Maybe I’m mistaken, and some of the other settings that look to be FITS specific effect raw files too?

If your DSLR is too recent then it is not well handled by LibRAW. In this case you have to wait for an update.

I see you are transforming to ser. Could you try converting to normal fits instead?

Same result. Forgot to include that in the original post but there was no change.

The 7D II is nearly a decade old, and what’s more these files worked fine in the previous version of Siril. It’s got to be something that changed in the 1.2.0 version.

Apparently you do a SER conversion.
It could be the issue. Try to avoid it.

Edit: already said by @cissou8

I have a Canon 90D and 77D, both newer than Canon 7D II. Both work correctly for me in Siril 1.20 when converting to FITS.

1 Like