Siril script errors

I’m having a very strange problem with Siril. I am running version 1.00. It has worked perfectly so far, until this morning. I ran a batch of images through the OSC_Preprocessing script and they worked fine. I followed with another batch of images, and Siril gave the error as follows: Running command: requires
15:18:09: # Convert Bias Frames to .fit files
15:18:09: Running command: cd
15:18:09: ‘biases’ No such file or directory
15:18:09: Error in line 24: ‘cd’.
15:18:09: Exiting batch processing.
15:18:09: Setting CWD (Current Working Directory) to ‘C:\Users\brian\Pictures\process’
15:18:09: Script execution failed.
I have made no changes to these directories and they are all still in the directory. I removed Siril and redownloaded it–same problem. I even went back to v0.99.6, and I still get the same errors. This has to be something obvious, but I am missing it. Any help much appreciated!
Brian

Fixed it! I normally delete the contents of the process directory, but not the directory itself. For some reason, Siril was seeing process as the home directory and I could not move it from this “fixation.” Completely deleting the directory fixed it.

All the best,

Brian

Hello, you just have to check that the working directory is correctly set before starting a script.

I have used the scrip OSC_Preprocessing dozen of times without an issue, now after installing the last SirIL version 1.0.1 the scrip is failing, any Idea what is happening ? The issue happens after it finishes to stack and save the Bias Frames.

Thank You,
20:46:48: # Stack Bias Frames to bias_stacked.fit
20:46:48: Running command: stack
20:46:48: Stacking sequence bias_
20:46:48: Processing all images in the sequence (30)
20:46:48: Stacking result will be stored as a 32-bit image
20:46:48: Using 30792 MB memory maximum for stacking
20:46:48: We have 16 parallel blocks of size 251 (+0) for stacking.
20:46:48: Starting stacking…
20:46:50: Pixel rejection in channel #0: 0.284% - 0.335%
20:46:51: Rejection stacking complete. 30 images have been stacked.
20:46:51: Integration of 30 images:
20:46:51: Pixel combination … average
20:46:51: Normalization … none
20:46:51: Pixel rejection … Winsorized Sigma Clipping
20:46:51: Rejection parameters … low=3.000 high=3.000
20:46:51: Background noise value (channel: #0): 4.323 (6.596e-05)
20:46:51: Saving FITS: file bias_stacked.fit, 1 layer(s), 6016x4016 pixels
20:46:51: Execution time: 2.89 s.
20:46:51: Setting CWD (Current Working Directory) to ‘/Users/leandrochecchinato/Documents/SIRIL.nosync/Messier 101’
20:46:51: Script execution failed.

hello, you have this problem with version 1.0.1 ?

Yes version 1.0.1 on a Mac OS.

I just installed back the 1.0.0 it’s working like a charme.

it looks like the mac os installer for 1.0.1 is incorrect, if you reinstall it, can you tell us the commit number written in the about window, available from the menu on the top right, the button with the 3 horizontal bars?

Due to an error in the MacOS package, we have removed the 1.0.1 version from the website for macOS only.

Tomorrow we will have the new version again. Sorry for the inconvenience.

Dear @LeandroCHT : you can now download the right version.
Sorry for the issue.

1 Like

I have the same problem downloaded an update to version 1.0.2 commit da080c48

What is your issue.
This bug is fixed and scripts are running well now.

So I guess the issue is now on your side.

Hi
When I run the script after loading the data I get an error message line 24 failed no biases found or directory I downloaded an update yesterday to version 1.0.2. I deleted all of the data in the working directory maybe I could delete the program and then reload it?

Reinstalling the software won’t help. I bet you are not in the right working Directory.
But without screenshot it is difficult to say.

Hi all appears good now