SirilIc errors. darks.seq, flats.seq etc

creating a new topic with correct title.

I came across SirilIc yesterday for processing and stacking multiple exposures of same objects. Great tool.

When I ran the tool, I got some errors in the console. It was complaining for darks.seq, flats.seq etc missing for all my sets. When I looked at the files I see “darks_.seq”, “flats_.seq” are created instead of darks.seq, flats.seq. Is this bug ? I tried manually changing those to darks_.seq to darks.seq etc and that seems to resolve but is there a way to fix this for good?

Another question, the final image came as B/W. What is the setting to get RGB output?


  1. Since version 0.99.6, Siril has added an underscore in the sequence name. To keep compatibility, Siril tries both sequences ( with and without ‘__’ ). For example, Siril tries to read offsets.seq, and if he fails, he tries offsets_.seq.

These are not really errors but more information. I have to ask the Siril team to remove these messages from siril, it is confusing.

  1. What type of camera do you use? DSLR, OSC, mono ?

I use OSC ASI533.

this is not normal.

Could you send me the project file and the generated script so that I can analyze the parameters?

For your color camera, you must check the “OSC” (or “CCD”) box in the color frame.


ok. I think the build that I have is CCD. I’ll check that and try.