Slow launch and image loading (5.0-r1 GTK2/GTK3 on Win10)

First off - thanks for all the hard work that must have gone into RT - I’ve been looking for something a bit more sophisticated to manage my RAWs than what Canon ships with their cameras, and I really like what I’ve seen so far.

Now, I’ve installed RT5 on my desktop and laptop (Win10 both), and everything looks the same, but the load times are staggeringly different. They are both installed from the same download from the official site “”.

Install: Lappy Desktop
Launch time: 10-15s 4-7 minutes
Launch CPU: ~16% ~0-1%
CR2 Load: 1 - 2s 10-12s
Load CPU: ~10% 8% for 2s, then 0% for 8s

I also had a look at disk usage during launch on my desktop, and it’s essentially idle for the most part (in both reads/writes/s and bytes/s).

What’s the best way for me to find out what RT is waiting for? There are no warning messages.

PS: Tried most of the stuff in these threads:

e.g.: Setting the clut location in the options file to a known empty folder (instead of the default non-existent folder), and nuking the options file altogether.

I’ve been been too lazy to revert to GTK2/32bit for testing, but I can if you here recommend it. (And I suspect we should be able to get GTK3 working, as that looks like where RT is headed.)


Additional investigation - the options screen also takes an aeon to load, with idle CPU/Disk and RT acting as “Not responding” until it finally arrives.

I in fact have a number of similarities with the “Long time to load Rt on Win 10 64bit” thread above.

Are you using anti virus?


Yes, same on both machines.

I disabled it for another trial on my desktop…very similar result.

Another experiment - installed RT 5.0 GTK2 32-bit on my desktop, and the same issue remains.

(GTK3 Uninstalled, and options file removed)

Did you launch rawtherapee-debug.exe instead of rawtherapee.exe by accident?

No, but you have given me an idea… let me see what I can find.

(Using start menu entry, which I just confirmed points to the right .exe)

The very long start time on your desktop machine is a clear indicator for the drive A: bug.
Do you use Single Editor or Multi Table Editor Tab mode?
In Single Editor Tab mode the drive A: bug should have no influence on load time of raw files

Maybe @rlx009 has a hint. He had the same issue

Heckflosse, thank you. To be honest, I was not yet familiar with the single/multi tab options, as I had learned to avoid the setting browser as a result of the long delays.

First - I can confirm that disabling “Drive A” in device manager (not BIOS) has made a big difference. However, I have been using “Single Editor Tab Mode, Vertical Tabs” the whole time.

So, some new experiments:
1a) Launch time for Single Editor Tab Modes now down to ~10s! :smiley:
1b) Render time for opening my CR2 files, about 2s. :smiley:
2a) Launch time for METM is still around 1-2 minutes
2b) METM CR2 load is still around 10s
3) Playing with the options…these durations appear to depend on the most recent thing I have put in the layout options, rather than how I launched the program.

I guess I will look at diabling the A Drive in BIOS on my next restart.

@bachango do you still get the METM delays using a recent GTK3 dev build?

So…restarted my computer and deactivated the drive in BIOS, just to make sure. Also went back to the most recent GTK3 build (@Morgan_Hardwood)

Some more checks…MEOW interface appears to take about 30s to load now, which is manageable. CR2 Load is still around 15s, and the options screen around 10 seconds.

SETM seems to be about the same to launch (20-30s), but around 2s to load CR2s.

Maybe the behaviour is normal - if RT has a lot of overhead to create the extra editor windows… (As I said, I am a new user!)

Otherwise, given the sensitivity to the A:, could it be that GTK is pinging my 4 mapped network drives, and other optical junk? Or is the bug specifically A:?

@bachango could you paste the whole version string?
It will look something like this, e.g. 5.0-r1-gtk3-47-gac882d2f.

Sorry for the slow reply - a few days in a row late home from work…

To your request… 5.0-r1-gtk3-??-50114c1

Not quite right, couldn’t figure out the middle number, but here is the dump from the version file:

Version: 5.0-r1-gtk3 Branch: 5.0-r1-gtk3 Commit: 50114c1 Commit date: 2017-02-01 Compiler: gcc 5.3.0 Processor: generic x86 System: Windows Bit depth: 64 bits Gtkmm: V3.18.0 Build type: release Build flags: -m64 -mwin32 -mthreads -std=gnu++11 -mtune=generic -Werror=unused-label -fopenmp -Werror=unknown-pragmas -msse -msse2 -mwindows -fopenmp -Wno-aggressive-loop-optimizations -DNDEBUG -O3 Link flags: -m64 -mwin32 -mthreads -static-libgcc -mtune=generic -mwindows -s -O3 OpenMP support: ON MMAP support: ON

@bachango you are using the latest official GTK3 release, not a dev build. You can get one from Download RawTherapee development builds
The latest version there at the time of writing is