[SOLVED]: 4.6.0: bad export

dt4.6.0 on opensuse leap 15.5.

The export is much, much more overexposed than the image within dt darkroom view or the lightroom view as shown with the screen capture. The jpeg is top left and the rest is dt.

This is with ristretto but it’s the same with geeqie.

The export options are:


  1. Am I doing something?
  2. Are other people having similar problem?
  3. How do I track what’s wrong?


I am not an expert at the problem you have here so I defer to others who may answer. Here are my settings which work well for me . Looking at yours I feel you are achieving nothing advantageous setting image quality to 100% but that is not your problem. Maybe the chroma subsampling settings or image intent settings are the issue? But I really don’t know.


I just tried your settings (except for the target storage location) and it’s still the same: very over-exposed.

Here are my settings.



Try changing the intent settings. I am really just taking stabs in the dark here and will defer to more experienced people when they respond to you. Another issue could be color management settings.

I don’t recognize the image viewing application, what is it and is it color managed?

Intent does nothing with the default DT sRGB profile…it has not tables embedded for the different rendering intents…

What is your display profile set to in DT… vs what profile is being used by the OS and perhaps by the viewers… are all set the same?? Its best to specify them everywhere if possible to be sure you are comparing apples to apples…

The screen capture is with Ristretto but it’s the same with Geeqie.

Everything is sRGB.


Apart from colour management issues (viewer colour managed or not): there are some modules, whose effect depends on resolution; this usually manifests as brightness/contrast change.
On the master branch, which I use, there is a new button to force this in the darkroom, without zooming in to 100% (at the expense of performance), but I don’t think it exists in 4.6.0:

Do you get the problem with other images (say, landscapes with colour)? The problem seems to be more frequent with contrasty B&W.

To see if that affects your image:

  • zoom in to 100% - does the image change (unfortunately you won’t see the whole image)?
  • when exporting, you have the option high quality resampling. When enabled, it processes the image ‘at 100% zoom’, and scales down the result; when disabled, it scales down early, which means you get better performance, but the same problem that the non-100% view of the darkroom has may occur. If that is the root cause of your problem, exporting at a size similar to the dimensions of the darkroom editor area, with high quality resampling disabled, should result in an image which looks like what you see in the darkroom. I see you have already tried that option, but were the dimensions similar to your darkroom editor’s preview? Since your first screenshot, which is not full screen, is 1961 pixels wide, and the viewer showing the exported image shows an image width of 3340 pixels, that could be the case; but then shots of your export dialogue show a target resolution of 1200x1200 pixels with high quality resampling enabled, and then 1080 x 1080 with it disabled.

If the experiment shows this scaling issue affects your image, you must use the 100% zoom to check brightness, and export with high quality resampling enabled. Alternatively, you must judge brightness without zooming in, and export at resolutions close to the darkroom editor preview’s dimensions, with high quality resampling disabled.

Lastly, do you, by chance, have options like prefer performance over quality turned on?

Surely not your display profile?

Yes, Just tried other images

I have tried with both high quality resampling on and off.

It is turned off.

I went back to some other previously processed images with 4.4.1 and re-exported them with 4.6.0 and they are all highly over-exposed at the export.

Have other people complained about this? I don’t remember.
Something is wrong between 4.6.0 and my setup.

How can I go back to dt4.4.1 or 2? Delete all the dt and keep the xmps? or is there a better way?


Can you share an image + xmp?

Can you try reimporting the exported tiff or jpg into darktable to see if it looks like the raw or it also looks bright? If it looks the same, it usually means a color management problem.

Sorting out the problem would be more beneficial in the long run, I think.
You can of course delete darktable and revert to a saved version of config + database. Darktable creates a backup of the database when you upgrade. See
INSTALL last version - #9 by kofa and INSTALL last version - #11 by kofa (on Linux it’s the same, but the files are in ~/.config/darktable).
If you edited the XMP files, darktable 4.6 may have updated them in a way that 4.4 won’t be able to read. But 4.6 is very nice, I really suggest that you let us help you figure out and solve the problem.

raw file + xmp + exported jpeg

pixls.us.zip (18.4 MB)


BTW, it’s not just this images but all the others from: Canon 7D + Canon 7Dmk2 + Fuji X-M1 + Fuji X-T10 + Fuji X-Pro2


Your jpg and the processing from the xmp look identical in my system.

Are you saying that when you open the raw+xmp, in the darkroom view it’s also over-exposed?

Because it’s not on mine.

Reply #2:

Thanks: Solved.

Like I mentioned originally that it could be my system. In fact it was my settings.

Somehow (I don’t know how), but the display profile in the lighttable bottom right was set to linear rec709 rgb. Changed it to srgb.Done/Fixed


Can you share your display profile setting in dt?

I just saw your edit. Display profile should be set to system and not go srgb.

Like I said. :wink: