(solved) Building darktable - GraphicsMagick fail

build
darktable

(Roel) #1

I’ve been trying to compile darktable for the first time on Windows using MSYS2 following the instructions here: https://github.com/darktable-org/darktable/blob/master/packaging/windows/BUILD.txt

However I run into a problem while building:

-- Up-to-date: D:/C/msys64/opt/darktable/lib//libgphoto2_port
-- Up-to-date: D:/C/msys64/opt/darktable/lib//libgphoto2_port/0.12.0
-- Up-to-date: D:/C/msys64/opt/darktable/lib//libgphoto2_port/0.12.0/disk.dll
-- Up-to-date: D:/C/msys64/opt/darktable/lib//libgphoto2_port/0.12.0/ptpip.dll
-- Up-to-date: D:/C/msys64/opt/darktable/lib//libgphoto2_port/0.12.0/usb1.dll
CMake Error at src/cmake_install.cmake:149 (file):
  file INSTALL cannot find
  "D:/C/msys64/mingw64/bin/../lib/GraphicsMagick-1.3.28/modules-Q8/coders".
Call Stack (most recent call first):
  cmake_install.cmake:38 (include)


make: *** [Makefile:86: install] Error 1

I am a little clueless on how to solve this issue. GraphicsMagick has been installed. Any ideas?


(Mica) #2

Do you have the file/folder D:/C/msys64/mingw64/lib/GraphicsMagick-1.3.28/modules-Q8/coders present? If not, you need it!


(Roel) #3

No, but I have GraphicsMagick-1.3.29 there. Would it be possible the build script didn’t pick up on the right version? How / where can I check this?


(Roel) #4

I think I found the culprit. In build\src\cmake_install.cmake there is a (hardcoded?) reference to the 1.3.28 version.

Let me check what happens if I just clear my build folder and try again.

Edit: nope, the version stays 1.3.28 even though 1.3.29 seems to be installed.

Edit 2: this value seems to come directly from darktable\cmake\windows-macros.cmake. But apparently no longer reflects the current up to date version of GraphicsMagick. Seems a bit tricky to hardcode versions in your makefile, or am I missing something? @houz?


(Mica) #5

You’ll want to ping @peterbud for windows issues as well :slight_smile:


#7

Yes, it’s unfortunately still hard-coded. There is an open PR since 20 days to update GraphicsMagick in the install to 1.3.29, but it has not been merged yet:


(Roel) #8

Mea culpa for not having done my research properly! Thanks for the responses, it made me a little wiser and darktalble compiles now :slightly_smiling_face:


#9

Ah right, I had that locally fixed for the last release already but never managed to push (I don’t trust Windows enough to put ssh keys into the VM).