[Solved] Compiling fails -- libgomp.so "missing"

Just for info. I installed Xubuntu 24.04 last week and today I recompiled RawTherapee. Everything went fine untel 99%, then ld complained that the package libgomp.so was missing.

[ 98%] Building CXX object rtgui/CMakeFiles/rth.dir/xtransprocess.cc.o
[ 99%] Building CXX object rtgui/CMakeFiles/rth.dir/xtransrawexposure.cc.o
make[2]: *** Er is geen regel om doel '/usr/lib/gcc/x86_64-linux-gnu/11/libgomp.so' te maken, nodig voor 'rtgui/rawtherapee'.  Gestopt.
make[2]: *** Wachten op onvoltooide taken...
[ 99%] Building CXX object rtgui/CMakeFiles/rth.dir/zoompanel.cc.o
make[1]: *** [CMakeFiles/Makefile2:191: rtgui/CMakeFiles/rth.dir/all] Fout 2
make: *** [Makefile:136: all] Fout 2

So I searched for this folder: /usr/lib/gcc/x86_64-linux-gnu/11 but that didn’t exist. Instead there was a subfolder 13 and that one contained libgomp.so.

A quick workaround was to create the directory “11” next to 13 and to copy the contents of 13 to 11. Now RT compiles fine.

I also tried to change line 2697 in the file apps/rawtherapee/rtgui/CMakeFiles/rth.dir from 11 to 13 but that didn’t work.

I have no idea if this is only related to Xubuntu 24.04, or that it affects other newer distros as well.

Regards, Paul.

I have libgomp packaged installed on Fedora 40 and RT compiles fine:

$ rpm -qa|grep gomp

Was it a clean build? If not, re-run the configure step and try compiling again. Alternatively, delete the build folder and start fresh. Library errors are usually the result of updating the system without re-configuring. The configure step finds the libraries.

Hello, I did a reconfigure before compiling but that resulted in named error above.

A fresh install, starting with “git clone”, did the trick however.

Thanks for your help.

You can use

git clean -d -x -f


git clean -dxf

to reset the working space to what’s in the repo, removing all generated files (everything that is not in the repo).

Thanks @kofa. In fact it’s the second time that you tell me this, but I forgot! :upside_down_face:

It’s added now to my “how to compile” notes.