[SOLVED] False colours for EOS 40D photos in 5.9 (OK in 5.8)


I recently looked at some of my old Canon 40D photos in RT 5.9 dev build and was surprised to see that, for lots of them, the thumbnails and editor views were showing wildly false colours. I looked at the same photos in 5.8 and they look normal.

I am running on linux mint 21.1. I closed RT 5.9 and renamed the ~/.config/RawTherapee5-dev directory to a temporary name and restarted RT 5.9 so that it re-created the directory with default settings. However, it still showed the photos in the false colours.

So far the only photos that are showing this problem are from the 40D, but some 40D photos are not affected. I haven’t been able to identify any obvious differences between the two groups of affected and unaffected photos.

Here are a couple of screenshots of thumbnails the same directory, first in 5.9 dev build, then in 5.8.

Is this a known issue?

I’ve just noticed that some of the 40D photos that look OK in thumbnails in 5.9 dev, actually show false colours in the editor:

Canon EOS 40D raw and sraw files appear to have correct thumbnails and open correctly in the Editor in 23408bfcb.

Close RawTherapee and clear your cache. If problems persist, How to write useful bug reports - RawPedia

1 Like

Thanks for the suggestion about the cache. I forgot to mention in my earlier posts that I had tried the two options in the context menu for clearing the cache, but they had no effect on the false colours. I also tried the “Clear” button in Preferences → File Browser, but that also had no effect.

However, I have just closed RT 5.9 dev, and renamed the ~/.cache/RawTherapee5-dev directory. When I restarted RT 5.9 dev, it re-created that directory and now all the 40D photos are being shown in the correct colours.


Just an update to mention that this issue comes back every time the build-rawtherapee downloads and builds a new version of RT 5.9 dev.

As before, it only affects photos from the Canon 40D and not any other camera.

Each time I have to delete the ~/.config/RawTherapee5-dev and ~/.cache/RawTherapee5-dev directories. However, I can’t just delete them both and then start RT dev. That doesn’t completely fix the problem.

The steps that mostly work are:

  1. Close RT dev.
  2. Delete ~/.config/RawTherapee5-dev.
  3. Start RT dev.
  4. Canon 40D thumbnails look OK, but Editor still show false colours.
  5. Close RT dev.
  6. Delete ~/.cache/RawTherapee5-dev.
  7. Start RT dev
  8. Canon 40D thumbnails and Editor show normal colours.

But sometimes even that is not enough and I have to repeat steps 5 through 8 a second time to get it to show the normal colours.

It’s really strange how it only affects photos from the 40D and not the 7DMkII, 20D or G1X.

I’ve ran into something similar (the same?) as what you describe months ago.

RAWs from certain Canon type cameras (and canon only), both cr2 and cr3 variants, turned up pink. Sometimes only in the file browser, sometime when opened in the edit window and sometimes both.

I tried multiple things and, like you, cleaning the cache (both manually and from the preference section) temporarily solved this problem.

Turns out that if I build with WITH_LTO=ON I see this issue and if I build with WITH_LTO=OFF I do not see this issue.

At the time I thought that this was an issue specific to my environment (older Debian, running multiple RawTherapee versions and having some shared RAWs/files). I also hadn’t seen any mentione of this behaviour on GitHub.

As mentioned by @Morgan_Hardwood, you should file a detailed bug report for this one.

Thanks for your reply.

I have opened the following bug report: RT 5.9 dev shows false colours for Canon 40D photos each time it is rebuilt on linux · Issue #6720 · Beep6581/RawTherapee · GitHub