[SOLVED] Is there a 24 node limit in the left pane of Curve Editor & Dope Sheet?

solved

#1

I have >24 nodes handling fading and positioning images in an educational video.
I need to offset the keyframes to synchronize with the audio track.
But I can only get 24 of them to show up at the same time in the left pane
(a huge problem when I need to offset ALL at once).

If I go to the Node Graph and double click on one that’s missing,
then go back to the Dope Sheet, it has popped up at the bottom of the list… but
the previous topmost item is now gone.
There seem to only be room for 24 items (nodes) in the list.

Anyone who knows anything about this?

Thanks in advance.


#2

At the top left of the properties panel you can set the maximum number of node properties, I think the default is 24. Just set it to 99 or whatnot and you should get a maximum of 99 slot’s in the dope sheet as well. This setting is also available in preferences > user Interface.

Cheers,
Josef


#3

Yes! :smile:
That solved my problem.
(But not immediately…)

Huge thanks @josef

Long story to help others:

The left pane of the Dope Sheet is populated with all properies that have keyframes…
BUT ONLY if their property panel is OPEN in the properties window.
This is normally the case, unless you hit the upper limit, in which case the first opened will be closed.
So, increasing the limit to 99 (or 100 seems to be max) will help a lot.
Tool tips and the text in the settings dialog suggests that setting it to “0” means “unlimited”.
This does NOT work.

SOLUTION:
Increase the property panel limit to 99, and double-click ALL nodes with keyframes in the Node Graph in order to open their properties.